summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:35:15 +0200
committersl1pkn072015-06-08 20:35:15 +0200
commitba69394d58f0deb6bef6155d6eff5948cc9c98cc (patch)
tree817eba69ad302b5693e29a4a259b266696b2f955
downloadaur-ba69394d58f0deb6bef6155d6eff5948cc9c98cc.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7b61e133b0ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-histogram-git
+ pkgdesc = Plugin for Vapoursynth: histogram (GIT version)
+ pkgver = v1.0.4.ge2b45ed
+ pkgrel = 1
+ url = https://github.com/dubhater/vapoursynth-histogram
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-histogram
+ conflicts = vapoursynth-plugin-histogram
+ source = histogram::git+https://github.com/dubhater/vapoursynth-histogram.git
+ md5sums = SKIP
+
+pkgname = vapoursynth-plugin-histogram-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ff1b38e0333
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=histogram
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v1.0.4.ge2b45ed
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url="https://github.com/dubhater/vapoursynth-${_plug}"
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+
+source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
+md5sums=('SKIP')
+_gitname="${_plug}"
+
+pkgver() {
+ cd "${_gitname}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+build() {
+ cd "${_gitname}"
+ ./autogen.sh
+ ./configure --prefix=/usr --libdir=/usr/lib/vapoursynth
+ make
+}
+
+package(){
+ cd "${_gitname}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 README "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
+}