summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-09-10 19:54:28 +0200
committersL1pKn072017-09-10 19:54:28 +0200
commit49d87842c9f075fdab747399d1ed2a9232c51f2b (patch)
treebcd6df04d2becb2d2439b1269deaff00616d7baa
downloadaur-49d87842c9f075fdab747399d1ed2a9232c51f2b.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD40
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b7671f6b36b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Sep 10 17:54:27 UTC 2017
+pkgbase = vapoursynth-plugin-hqdn3d-git
+ pkgdesc = Plugin for Vapoursynth: hqdn3d (GIT version)
+ pkgver = r2.c36c1b8
+ pkgrel = 1
+ url = https://github.com/Hinterwaeldlers/vapoursynth-hqdn3d
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-hqdn3d
+ conflicts = vapoursynth-plugin-hqdn3d
+ source = hqdn3d::git+https://github.com/Hinterwaeldlers/vapoursynth-hqdn3d.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-hqdn3d-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5404c29f3891
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=hqdn3d
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r2.c36c1b8
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url="https://github.com/Hinterwaeldlers/vapoursynth-${_plug}"
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/Hinterwaeldlers/vapoursynth-${_plug}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ #echo "$(git describe --long --tags | tr - .)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${_plug}"
+ ./autogen.sh
+}
+
+build() {
+ cd "${_plug}"
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib/vapoursynth
+ make
+}
+
+package(){
+ cd "${_plug}"
+ make DESTDIR="${pkgdir}" install
+}