summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-02-05 16:39:25 +0100
committerGustavo Alvarez2016-02-05 16:39:25 +0100
commitb6bbcd8f1c1db112edb8c97fe2580aefee4dccbb (patch)
tree59ee227fb316dbac41d2f84966156ba9621fd1f6
parent54049f9fbc467d811e0b2dfc96984e69ada76537 (diff)
downloadaur-b6bbcd8f1c1db112edb8c97fe2580aefee4dccbb.tar.gz
Use patch instead of sed
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD12
-rw-r--r--patch.patch13
4 files changed, 22 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff1d4f13a71a..4faaefa03a2c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Fri Dec 25 22:42:57 UTC 2015
+# Fri Feb 5 15:39:03 UTC 2016
pkgbase = vapoursynth-plugin-inpaint-git
pkgdesc = Plugin for Vapoursynth: inpaint
pkgver = r2.dafa5b5
@@ -11,7 +11,9 @@ pkgbase = vapoursynth-plugin-inpaint-git
depends = vapoursynth
depends = opencv
source = inpaint::git+https://github.com/invisiblearts/VapourSynth-Inpaint.git
+ source = patch.patch
sha1sums = SKIP
+ sha1sums = a1bedda17d7025f0131b3e0fb12ac622cdd69f0e
pkgname = vapoursynth-plugin-inpaint-git
diff --git a/.gitignore b/.gitignore
index 05c6d4d4c97b..d5a163ad2410 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.gitignore
!.SRCINFO
!PKGBUILD
+!patch.patch
diff --git a/PKGBUILD b/PKGBUILD
index 75f606e566c4..63887c1c0c51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,10 @@ license=('GPL')
depends=('vapoursynth'
'opencv'
)
-source=("${_plug}::git+https://github.com/invisiblearts/VapourSynth-Inpaint.git")
-sha1sums=('SKIP')
+source=("${_plug}::git+https://github.com/invisiblearts/VapourSynth-Inpaint.git"
+ 'patch.patch')
+sha1sums=('SKIP'
+ 'a1bedda17d7025f0131b3e0fb12ac622cdd69f0e')
pkgver() {
cd "${_plug}"
@@ -24,11 +26,7 @@ prepare(){
cd "${_plug}"
rm -fr VSHelper.h VapourSynth.h
- sed -e 's|vapoursynth.h|VapourSynth.h|g' \
- -e 's|vshelper.h|VSHelper.h|g' \
- -e 's|"VapourSynth.h"|<VapourSynth.h>|g' \
- -e 's|"VSHelper.h"|<VSHelper.h>|g' \
- -i *
+ patch -p1 -i "${srcdir}/patch.patch"
echo "all:
g++ -c -std=gnu++11 -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) -o Inpaint.o Inpaint.cpp
diff --git a/patch.patch b/patch.patch
new file mode 100644
index 000000000000..c0b88c8ec682
--- /dev/null
+++ b/patch.patch
@@ -0,0 +1,13 @@
+diff --git a/Inpaint.h b/Inpaint.h
+index 0325d7b..de056d8 100644
+--- a/Inpaint.h
++++ b/Inpaint.h
+@@ -1,7 +1,7 @@
+ #ifndef INPAINT_H
+ #define INPAINT_H
+
+-#include <vapoursynth.h>
++#include <VapourSynth.h>
+ #include <VSHelper.h>
+ #include <opencv2/opencv.hpp>
+