summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-12-24 22:48:50 +0100
committersl1pkn072015-12-24 22:48:50 +0100
commitcedc5331ab71fe3458c247b3ae08299207558ecf (patch)
tree9343313f1d0169ac27f647418cbc8ceb0d59a402
downloadaur-cedc5331ab71fe3458c247b3ae08299207558ecf.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..134f44b973f1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Thu Dec 24 21:48:50 UTC 2015
+pkgbase = vapoursynth-plugin-inpaint-git
+ pkgdesc = Plugin for Vapoursynth: inpaint
+ pkgver = r2.dafa5b5
+ pkgrel = 1
+ url = https://github.com/invisiblearts/VapourSynth-Inpaint
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = vapoursynth
+ depends = opencv
+ source = inpaint::git+https://github.com/invisiblearts/VapourSynth-Inpaint.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-inpaint-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..44cc23865d84
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=inpaint
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r2.dafa5b5
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug}"
+arch=('i686' 'x86_64')
+url='https://github.com/invisiblearts/VapourSynth-Inpaint'
+license=('GPL')
+depends=('vapoursynth'
+ 'opencv'
+ )
+source=("${_plug}::git+https://github.com/invisiblearts/VapourSynth-Inpaint.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ #echo "$(git describe --long --tags | tr - .)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare(){
+ rm -fr VSHelper.h VapourSynth.h
+
+ sed -e 's|vapoursynth.h|VapourSynth.h|g' \
+ -e 's|vshelper.h|VSHelper.h|g' \
+ -e 's|"VapourSynth.h"|<VapourSynth.h>|g' \
+ -e 's|"VSHelper.h"|<VSHelper.h>|g' \
+ -i inpaint/*
+
+ echo "all:
+ g++ -c -std=gnu++11 -I. -fPIC ${CXXFLAGS} ${CPPFLAGS} $(pkg-config --cflags vapoursynth) inpaint/Inpaint.cpp -o Inpaint.o
+ g++ -shared -fPIC ${LDFLAGS} -o lib${_plug}.so Inpaint.o" > Makefile
+}
+
+build() {
+ make
+}
+
+package() {
+ install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+}