summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-08-13 14:41:56 +0200
committersL1pKn072017-08-13 14:41:56 +0200
commit21e809b015dbe45680cdb4415c2be5af78a751c5 (patch)
tree21d8013826938a0147400b52c29064acd499385d
downloadaur-21e809b015dbe45680cdb4415c2be5af78a751c5.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b87a0b77506
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Aug 13 12:41:56 UTC 2017
+pkgbase = vapoursynth-plugin-kagefunc-git
+ pkgdesc = Plugin for Vapoursynth: kagefunc (GIT version)
+ pkgver = r7.cfabb13
+ pkgrel = 1
+ url = https://github.com/Irrational-Encoding-Wizardry/kagefunc
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth-plugin-mvsfunc-git
+ depends = vapoursynth-plugin-fvsfunc-git
+ provides = vapoursynth-plugin-kagefunc
+ conflicts = vapoursynth-plugin-kagefunc
+ source = kagefunc::git+https://github.com/Irrational-Encoding-Wizardry/kagefunc.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-kagefunc-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dfb68cbf0586
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=kagefunc
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r7.cfabb13
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url='https://github.com/Irrational-Encoding-Wizardry/kagefunc'
+license=('GPL')
+depends=('vapoursynth-plugin-mvsfunc-git'
+ 'vapoursynth-plugin-fvsfunc-git'
+ )
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/Irrational-Encoding-Wizardry/kagefunc.git")
+sha256sums=('SKIP')
+
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ #echo "$(git describe --long --tags | tr - .)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package(){
+ cd "${_plug}"
+ install -Dm644 "${_plug}.py" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}