summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-10-19 23:13:32 +0200
committerGustavo Alvarez2016-10-19 23:13:32 +0200
commit7a20cee8eaf384a19e21aa906c2adb71060364b1 (patch)
treee6855bbaf33bdef9cf3bee9ee4b64d09edc99d50
parentc739b15d10fa80fdbbd28d22729291424d9abb87 (diff)
downloadaur-7a20cee8eaf384a19e21aa906c2adb71060364b1.tar.gz
bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e6244c1fafb9..70a7411ee600 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Jan 17 06:03:24 UTC 2016
+# Wed Oct 19 21:13:27 UTC 2016
pkgbase = vapoursynth-plugin-knlm-git
pkgdesc = Plugin for Vapoursynth: knlm (GIT version)
pkgver = r3
@@ -13,7 +13,7 @@ pkgbase = vapoursynth-plugin-knlm-git
provides = vapoursynth-plugin-knlm
conflicts = vapoursynth-plugin-knlm
source = knlm::git+https://gist.github.com/4788aa29cee72ac78361.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-knlm-git
diff --git a/PKGBUILD b/PKGBUILD
index 7a4c8a77eb04..26dcf1f31599 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,9 +15,9 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://gist.github.com/4788aa29cee72ac78361.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
-_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
pkgver() {
cd "${_plug}"
@@ -25,5 +25,7 @@ pkgver() {
}
package() {
- install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_sites_packages}/${_plug}.py"
+ install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
}