summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-01-17 07:03:24 +0100
committerGustavo Alvarez2016-01-17 07:03:24 +0100
commitc739b15d10fa80fdbbd28d22729291424d9abb87 (patch)
tree14bc5ceb6321bc88cf56445e8a952fc040a35f14
downloadaur-c739b15d10fa80fdbbd28d22729291424d9abb87.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6244c1fafb9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sun Jan 17 06:03:24 UTC 2016
+pkgbase = vapoursynth-plugin-knlm-git
+ pkgdesc = Plugin for Vapoursynth: knlm (GIT version)
+ pkgver = r3
+ pkgrel = 1
+ url = https://gist.github.com/4re
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = vapoursynth-plugin-knlmeanscl
+ depends = vapoursynth-plugin-fmtconv
+ provides = vapoursynth-plugin-knlm
+ conflicts = vapoursynth-plugin-knlm
+ source = knlm::git+https://gist.github.com/4788aa29cee72ac78361.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-knlm-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7a4c8a77eb04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=knlm
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r3
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='https://gist.github.com/4re'
+license=('GPL')
+depends=('vapoursynth-plugin-knlmeanscl'
+ 'vapoursynth-plugin-fmtconv'
+ )
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://gist.github.com/4788aa29cee72ac78361.git")
+sha1sums=('SKIP')
+
+_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ printf "r%s" "$(git rev-list --count HEAD)"
+}
+
+package() {
+ install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_sites_packages}/${_plug}.py"
+}