summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-02-10 22:07:34 +0100
committerGustavo Alvarez2016-02-10 22:07:34 +0100
commit2b6e8f0756da803c7328b3ae94ef2faa4a36d49a (patch)
tree10b903663e72acdcad83ebfdcd3adaff8fe7a577
parent2b0051490ee2c68fe619b433eba383bb31d6e26b (diff)
downloadaur-2b6e8f0756da803c7328b3ae94ef2faa4a36d49a.tar.gz
README.md -> DOC.md
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD21
2 files changed, 17 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ed73847e181..05f421b4366a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Wed Feb 10 21:07:26 UTC 2016
pkgbase = vapoursynth-plugin-knlmeanscl
pkgdesc = Plugin for Vapoursynth: knlmeanscl
pkgver = 0.7.4
- pkgrel = 1
+ pkgrel = 2
url = http://forum.doom9.org/showthread.php?t=171379
arch = i686
arch = x86_64
@@ -10,7 +12,7 @@ pkgbase = vapoursynth-plugin-knlmeanscl
makedepends = opencl-headers
depends = vapoursynth
depends = libcl
- source = https://github.com/Khanattila/KNLMeansCL/archive/v0.7.4.tar.gz
+ source = knlmeanscl-0.7.4.tar.gz::https://github.com/Khanattila/KNLMeansCL/archive/v0.7.4.tar.gz
sha1sums = ad180de5e244a97e6629dfdecee7b46e73e1b06a
pkgname = vapoursynth-plugin-knlmeanscl
diff --git a/PKGBUILD b/PKGBUILD
index 4ac5bdea9cf4..21e7ce19ea0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,14 +3,18 @@
_plug=knlmeanscl
pkgname=vapoursynth-plugin-${_plug}
pkgver=0.7.4
-pkgrel=1
+pkgrel=2
pkgdesc="Plugin for Vapoursynth: ${_plug}"
arch=('i686' 'x86_64')
url='http://forum.doom9.org/showthread.php?t=171379'
license=('GPL')
-depends=('vapoursynth' 'libcl')
-makedepends=('git' 'opencl-headers')
-source=("https://github.com/Khanattila/KNLMeansCL/archive/v${pkgver}.tar.gz")
+depends=('vapoursynth'
+ 'libcl'
+ )
+makedepends=('git'
+ 'opencl-headers'
+ )
+source=("${_plug}-${pkgver}.tar.gz::https://github.com/Khanattila/KNLMeansCL/archive/v${pkgver}.tar.gz")
sha1sums=('ad180de5e244a97e6629dfdecee7b46e73e1b06a')
# prepare() {
@@ -19,13 +23,14 @@ sha1sums=('ad180de5e244a97e6629dfdecee7b46e73e1b06a')
build() {
cd "KNLMeansCL-${pkgver}"
- ./configure --install=/usr/lib/vapoursynth \
- --extra-cxxflags="${CXXFLAGS} ${CPPFLAGS}" \
- --extra-ldflags="${LDFLAGS}"
+ ./configure \
+ --install=/usr/lib/vapoursynth \
+ --extra-cxxflags="${CXXFLAGS} ${CPPFLAGS}" \
+ --extra-ldflags="${LDFLAGS}"
make
}
package(){
make -C "KNLMeansCL-${pkgver}" DESTDIR="${pkgdir}" install
- install -Dm644 "KNLMeansCL-${pkgver}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ install -Dm644 "KNLMeansCL-${pkgver}/DOC.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/DOC.md"
}