summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-07-13 20:33:36 +0200
committersl1pkn072015-07-13 20:33:36 +0200
commit3777a8c357a71fec46c3e33fdb6e65cb67a6dd19 (patch)
treee9244dbaef44b123902d095a94efaf513726e7e1
parentea89a1dfa9899f55174e67c27330a944592376f1 (diff)
downloadaur-3777a8c357a71fec46c3e33fdb6e65cb67a6dd19.tar.gz
Update to 0.5.7
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD32
2 files changed, 14 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b5ddcc306fc9..c52839d1bd1d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vapoursynth-plugin-knlmeanscl
pkgdesc = Plugin for Vapoursynth: knlmeanscl
- pkgver = 0.5.6
+ pkgver = 0.5.7
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=171379
arch = i686
@@ -10,12 +10,8 @@ pkgbase = vapoursynth-plugin-knlmeanscl
makedepends = opencl-headers
depends = vapoursynth
depends = libcl
- source = https://dl.dropboxusercontent.com/u/6596386/vapoursynth-plugins/KNLMeansCL_v0.5.6.zip
- source = patch_h.patch::http://sl1pkn07.wtf/paste/view/raw/200696c6
- source = patch_cpp.patch::http://sl1pkn07.wtf/paste/view/raw/00c87ed0
- sha1sums = f65272737926d6227596eec6ca02918c943633c5
- sha1sums = c36e70bc1b2fe98e07c5c4afe8007b2c2a71676e
- sha1sums = ac7f7b3c5cd13ed348c823e36b85670f3d5f4393
+ source = https://github.com/Khanattila/KNLMeansCL/archive/v0.5.7.tar.gz
+ sha1sums = 2e4dbac2d0cab462a94e3ba193fea930d4901782
pkgname = vapoursynth-plugin-knlmeanscl
diff --git a/PKGBUILD b/PKGBUILD
index 6aee30f16d6a..0ff2261f1078 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=knlmeanscl
pkgname=vapoursynth-plugin-${_plug}
-pkgver=0.5.6
+pkgver=0.5.7
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug}"
arch=('i686' 'x86_64')
@@ -10,33 +10,23 @@ url='http://forum.doom9.org/showthread.php?t=171379'
license=('GPL')
depends=('vapoursynth' 'libcl')
makedepends=('git' 'opencl-headers')
-source=("https://dl.dropboxusercontent.com/u/6596386/vapoursynth-plugins/KNLMeansCL_v${pkgver}.zip"
- 'patch_h.patch::http://sl1pkn07.wtf/paste/view/raw/200696c6'
- 'patch_cpp.patch::http://sl1pkn07.wtf/paste/view/raw/00c87ed0')
-sha1sums=('f65272737926d6227596eec6ca02918c943633c5'
- 'c36e70bc1b2fe98e07c5c4afe8007b2c2a71676e'
- 'ac7f7b3c5cd13ed348c823e36b85670f3d5f4393')
+source=("https://github.com/Khanattila/KNLMeansCL/archive/v${pkgver}.tar.gz")
+sha1sums=('2e4dbac2d0cab462a94e3ba193fea930d4901782')
prepare() {
- (cd KNLMeansCL/src; find -type f -exec perl -pi -e 's/\r\n?/\n/g' "{}" \;)
- patch -d KNLMeansCL -p0 -i ../patch_h.patch
- patch -d KNLMeansCL -p0 -i ../patch_cpp.patch
-
- rm -fr KNLMeansCL/src/VapourSynth.h
- rm -fr KNLMeansCL/src/VSHelper.h
- sed -e 's|"VapourSynth.h"|<vapoursynth/VapourSynth.h>|g' \
- -e 's|"VSHelper.h"|<vapoursynth/VSHelper.h>|g' \
- -i KNLMeansCL/src/KNLMeansCL.h
-
- echo "all:
- g++ -o lib${_plug}.so ${CXXFLAGS} ${CPPFLAGS} ${LDFLAGS} "$(pkg-config --cflags vapoursynth)" KNLMeansCL/src/KNLMeansCL.cpp -std=c++11 -fPIC -shared -lOpenCL" > Makefile
+ chmod +x "KNLMeansCL-${pkgver}/configure"
}
build() {
+ cd "KNLMeansCL-${pkgver}"
+ ./configure --install=/usr/lib/vapoursynth \
+ --extra-cxxflags="${CXXFLAGS} ${CPPFLAGS}" \
+ --extra-ldflags="${LDFLAGS}"
make
}
package(){
- install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
- install -Dm644 KNLMeansCL/README.txt "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.txt"
+ make -C "KNLMeansCL-${pkgver}" DESTDIR="${pkgdir}" install
+ install -Dm644 "KNLMeansCL-${pkgver}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}
+