summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-09-25 18:48:56 +0200
committersl1pkn072015-09-25 18:48:56 +0200
commit72fe41c2ba44de0ab90235b8d2971e5879d38e41 (patch)
treef55d5ca5e16a8e5eada7977babd4ce3162dac8f0
parente91b3149e2b56112e9569e3320864cf56efc79e2 (diff)
downloadaur-72fe41c2ba44de0ab90235b8d2971e5879d38e41.tar.gz
Update to 0.6.11
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 14 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0f731978a818..4e3f47222698 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = vapoursynth-plugin-knlmeanscl
pkgdesc = Plugin for Vapoursynth: knlmeanscl
- pkgver = 0.6.3.1
+ pkgver = 0.6.11
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=171379
arch = i686
@@ -10,8 +10,8 @@ pkgbase = vapoursynth-plugin-knlmeanscl
makedepends = opencl-headers
depends = vapoursynth
depends = libcl
- source = https://github.com/Khanattila/KNLMeansCL/archive/v0.6.3-1.tar.gz
- sha1sums = c37fd6618203aba6e9ea5c0995663032abcf2e66
+ source = https://github.com/Khanattila/KNLMeansCL/archive/v0.6.11.tar.gz
+ sha1sums = efdf3e36037303774eee369b6cc8b8d0abab7aaa
pkgname = vapoursynth-plugin-knlmeanscl
diff --git a/PKGBUILD b/PKGBUILD
index ca931b6e0917..363250077cb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=knlmeanscl
pkgname=vapoursynth-plugin-${_plug}
-pkgver=0.6.3.1
+pkgver=0.6.11
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug}"
arch=('i686' 'x86_64')
@@ -10,18 +10,22 @@ url='http://forum.doom9.org/showthread.php?t=171379'
license=('GPL')
depends=('vapoursynth' 'libcl')
makedepends=('git' 'opencl-headers')
-source=("https://github.com/Khanattila/KNLMeansCL/archive/v${pkgver//.1/-1}.tar.gz")
-sha1sums=('c37fd6618203aba6e9ea5c0995663032abcf2e66')
+source=("https://github.com/Khanattila/KNLMeansCL/archive/v${pkgver}.tar.gz")
+sha1sums=('efdf3e36037303774eee369b6cc8b8d0abab7aaa')
+
+prepare() {
+ chmod +x "KNLMeansCL-${pkgver}/configure"
+}
build() {
- cd "KNLMeansCL-${pkgver//.1/-1}"
+ cd "KNLMeansCL-${pkgver}"
./configure --install=/usr/lib/vapoursynth \
--extra-cxxflags="${CXXFLAGS} ${CPPFLAGS}" \
- --extra-ldflags="${LDFLAGS} -fopenmp"
+ --extra-ldflags="${LDFLAGS}"
make
}
package(){
- make -C "KNLMeansCL-${pkgver//.1/-1}" DESTDIR="${pkgdir}" install
- install -Dm644 "KNLMeansCL-${pkgver//.1/-1}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ make -C "KNLMeansCL-${pkgver}" DESTDIR="${pkgdir}" install
+ install -Dm644 "KNLMeansCL-${pkgver}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}