summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-07-02 23:35:45 +0200
committersl1pkn072015-07-02 23:35:45 +0200
commita2ac1e3aa1f26e406c46cdc5d7f60c4538209387 (patch)
tree3d326d6c21414fcef4c526fe07a22aa006f672cd
downloadaur-a2ac1e3aa1f26e406c46cdc5d7f60c4538209387.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD42
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..138e97648a82
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vapoursynth-plugin-knlmeanscl
+ pkgdesc = Plugin for Vapoursynth: knlmeanscl (GIT version)
+ pkgver = 0.5.6
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=171379
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ source = https://dl.dropboxusercontent.com/u/6596386/vapoursynth-plugins/KNLMeansCL_v0.5.6.zip
+ source = patch_h.patch::http://sl1pkn07.wtf/paste/view/raw/67987544
+ source = patch_cpp.patch::http://sl1pkn07.wtf/paste/view/raw/1c9d055d
+ sha1sums = SKIP
+ sha1sums = SKIP
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-knlmeanscl
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0dcdc1818ef4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=knlmeanscl
+pkgname=vapoursynth-plugin-${_plug}
+pkgver=0.5.6
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url='http://forum.doom9.org/showthread.php?t=171379'
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+source=("https://dl.dropboxusercontent.com/u/6596386/vapoursynth-plugins/KNLMeansCL_v${pkgver}.zip"
+ 'patch_h.patch::http://sl1pkn07.wtf/paste/view/raw/67987544'
+ 'patch_cpp.patch::http://sl1pkn07.wtf/paste/view/raw/1c9d055d')
+sha1sums=('SKIP'
+ 'SKIP'
+ 'SKIP')
+
+prepare() {
+ (cd KNLMeansCL/src; find -type f -exec perl -pi -e 's/\r\n?/\n/g' "{}" \;)
+ patch -d KNLMeansCL -p0 -i ../patch_h.patch
+ patch -d KNLMeansCL -p0 -i ../patch_cpp.patch
+
+# rm -fr KNLMeansCL/src/VapourSynth.h
+# rm -fr KNLMeansCL/src/VSHelper.h
+# sed -e 's|"VapourSynth.h"|<vapoursynth/VapourSynth.h>|g' \
+# -e 's|"VSHelper.h"|<vapoursynth/VapourSynth.h>|g' \
+# -i KNLMeansCL/src/KNLMeansCL.h
+
+ echo "all:
+ g++ -o "lib${_plug}.so" -std=c++11 ${CXXFLAGS} ${CPPFLAGS} ${LDFLAGS/,--as-needed/} "$(pkg-config --cflags vapoursynth)" -fPIC -shared -lOpenCL KNLMeansCL/src/KNLMeansCL.cpp" > Makefile
+}
+
+build() {
+ make
+}
+
+package(){
+ install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+ install -Dm644 KNLMeansCL/README.txt "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.txt"
+}