summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-10-10 02:20:39 +0200
committersL1pKn072021-10-10 02:20:39 +0200
commit535dce96f9e9d6b359fa68d768900dd50924770c (patch)
tree980704a51bca973daeeb671a135b9e24c41ad932
downloadaur-535dce96f9e9d6b359fa68d768900dd50924770c.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD37
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a60faa15fe9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = vapoursynth-plugin-lostfunc-git
+ pkgdesc = Plugin for Vapoursynth: lostfunc (GIT version)
+ pkgver = v1.0.g0a68168
+ pkgrel = 1
+ url = https://github.com/theChaosCoder/lostfunc
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth-plugin-adjust-git
+ depends = vapoursynth-plugin-havsfunc
+ depends = vapoursynth-plugin-oyster-git
+ depends = vapoursynth-plugin-mvtools
+ depends = vapoursynth-plugin-knlmeanscl-git
+ depends = vapoursynth-plugin-awarpsharp2-git
+ depends = vapoursynth-plugin-bm3d-git
+ provides = vapoursynth-plugin-lostfunc
+ conflicts = vapoursynth-plugin-lostfunc
+ source = lostfunc::git+https://github.com/theChaosCoder/lostfunc.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-lostfunc-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d62bc669bd42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=lostfunc
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v1.0.g0a68168
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url="https://github.com/theChaosCoder/lostfunc"
+license=('GPL')
+depends=('vapoursynth-plugin-adjust-git'
+ 'vapoursynth-plugin-havsfunc'
+ 'vapoursynth-plugin-oyster-git'
+ 'vapoursynth-plugin-mvtools'
+ 'vapoursynth-plugin-knlmeanscl-git'
+ 'vapoursynth-plugin-awarpsharp2-git'
+ 'vapoursynth-plugin-bm3d-git'
+ )
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/theChaosCoder/lostfunc.git")
+sha256sums=('SKIP')
+
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+package(){
+ cd "${_plug}"
+ install -Dm644 "${_plug}.py" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+}