summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-04-08 19:12:21 +0200
committersL1pKn072019-04-08 19:12:21 +0200
commit011c240f1533227e497553f751e11518d6adbe0e (patch)
tree57f4fade4a895b1264d2ce1c9f2e6d0c4f8b98fa
parent30d13d6820e7986f8616553f2b38b9a39522d500 (diff)
downloadaur-011c240f1533227e497553f751e11518d6adbe0e.tar.gz
bump
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 008804789f8f..8dc006aed6b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
# Generated by mksrcinfo v8
-# Sun Feb 14 04:45:04 UTC 2016
+# Mon Apr 8 17:12:16 UTC 2019
pkgbase = vapoursynth-plugin-lsmashsource-git
pkgdesc = Plugin for Vapoursynth: lsmashsource (GIT version)
- pkgver = r875.14b040e
+ pkgver = r935.3edd194
pkgrel = 1
- url = http://forum.doom9.org/showthread.php?t=167435
- arch = i686
+ url = https://forum.doom9.org/showthread.php?t=167435
arch = x86_64
license = LGPL
makedepends = git
+ makedepends = libavresample
depends = vapoursynth
- depends = glibc
depends = libavutil.so
depends = libavformat.so
depends = libavcodec.so
@@ -19,7 +18,7 @@ pkgbase = vapoursynth-plugin-lsmashsource-git
provides = vapoursynth-plugin-lsmashsource
conflicts = vapoursynth-plugin-lsmashsource
source = lsmashsource::git+https://github.com/VFR-maniac/L-SMASH-Works.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-lsmashsource-git
diff --git a/PKGBUILD b/PKGBUILD
index 3ef1f4088515..9f564636b70a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,27 @@
-# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
_plug=lsmashsource
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r875.14b040e
+pkgver=r935.3edd194
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
-arch=('i686' 'x86_64')
-url='http://forum.doom9.org/showthread.php?t=167435'
+arch=('x86_64')
+url='https://forum.doom9.org/showthread.php?t=167435'
license=('LGPL')
depends=('vapoursynth'
- 'glibc'
'libavutil.so'
'libavformat.so'
'libavcodec.so'
'libswscale.so'
'liblsmash.so'
)
-makedepends=('git')
+makedepends=('git'
+ 'libavresample'
+ )
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/VFR-maniac/L-SMASH-Works.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
@@ -29,7 +30,9 @@ pkgver() {
}
prepare() {
- rm -fr "${_plug}/VapourSynth/VapourSynth.h"
+ cd "${_plug}"
+
+ rm -fr VapourSynth/VapourSynth.h
}
build() {
@@ -38,6 +41,7 @@ build() {
--prefix=/usr \
--extra-cflags="${CFLAGS} ${CPPFLAGS} $(pkg-config --cflags vapoursynth)" \
--extra-ldflags="${LDFLAGS}"
+
make
}