summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:35:25 +0200
committersl1pkn072015-06-08 20:35:25 +0200
commit6680e3b3653de7281370157869743d0d3208c182 (patch)
tree7ea4d657b37b639ed1f05600aaea098651f36c99
downloadaur-6680e3b3653de7281370157869743d0d3208c182.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD40
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6042f7e8ccfd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vapoursynth-plugin-lsmashsource-git
+ pkgdesc = Plugin for Vapoursynth: lsmashsource (GIT version)
+ pkgver = r783.49b0813
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=167435
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = vapoursynth
+ depends = l-smash-git
+ provides = vapoursynth-plugin-lsmashsource
+ conflicts = vapoursynth-plugin-lsmashsource
+ source = lsmashsource::git+https://github.com/VFR-maniac/L-SMASH-Works.git
+ md5sums = SKIP
+
+pkgname = vapoursynth-plugin-lsmashsource-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2ef34e2981e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=lsmashsource
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r783.49b0813
+_pkgver="$(echo ${pkgver} | cut -d '.' -f1 | tr -d r)"
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url="http://forum.doom9.org/showthread.php?t=167435"
+license=('LGPL')
+depends=('vapoursynth' 'l-smash-git')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/VFR-maniac/L-SMASH-Works.git")
+md5sums=('SKIP')
+_gitname="${_plug}"
+
+pkgver() {
+ cd "${_gitname}"
+ echo "r$(git rev-list HEAD 2> /dev/null | wc -l | sed 's/ //g').$(git describe --always)"
+}
+
+prepare() {
+ rm "${_gitname}/VapourSynth/VapourSynth.h"
+}
+
+build() {
+ cd "${_gitname}/VapourSynth"
+ ./configure --prefix=/usr --extra-cflags="$(pkg-config --cflags vapoursynth)"
+ make
+}
+
+package(){
+ cd "${_gitname}/VapourSynth"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 README "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
+
+}