summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072020-03-22 17:39:04 +0100
committersL1pKn072020-03-22 17:39:04 +0100
commit87659fdc8b0cab8f36afd745ceade9219fd48915 (patch)
treef70a35dc2dfc4b9df48f6855ee49a24fd10c256c
parentaff79889d59dd9377fdc84f820e62fe697852270 (diff)
downloadaur-87659fdc8b0cab8f36afd745ceade9219fd48915.tar.gz
bump
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD32
-rw-r--r--patch.patch60
4 files changed, 14 insertions, 89 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a90f68e49f4..aae2b0825a11 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
-# Generated by mksrcinfo v8
-# Sun Apr 14 20:01:23 UTC 2019
pkgbase = vapoursynth-plugin-lsmashsource-git
pkgdesc = Plugin for Vapoursynth: lsmashsource (GIT version)
- pkgver = r935.3edd194
+ pkgver = r1036.86f757d
pkgrel = 1
url = https://forum.doom9.org/showthread.php?t=167435
arch = x86_64
license = LGPL
makedepends = git
- makedepends = libavresample
+ makedepends = meson
depends = vapoursynth
depends = libavutil.so
depends = libavformat.so
@@ -17,10 +15,8 @@ pkgbase = vapoursynth-plugin-lsmashsource-git
depends = liblsmash.so
provides = vapoursynth-plugin-lsmashsource
conflicts = vapoursynth-plugin-lsmashsource
- source = lsmashsource::git+https://github.com/VFR-maniac/L-SMASH-Works.git
- source = patch.patch
+ source = lsmashsource::git+https://github.com/HolyWu/L-SMASH-Works.git
sha256sums = SKIP
- sha256sums = cb9603da5bd264ae5a1917490069d5dd564714bc0bd8aa5c46ad5b7f269170e1
pkgname = vapoursynth-plugin-lsmashsource-git
diff --git a/.gitignore b/.gitignore
index 8a2e0bc8bce4..05c6d4d4c97b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,3 @@
!.gitignore
!.SRCINFO
!PKGBUILD
-patch.patch
diff --git a/PKGBUILD b/PKGBUILD
index 27b6d349d966..1b62fa70196d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=lsmashsource
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r935.3edd194
+pkgver=r1036.86f757d
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -16,16 +16,12 @@ depends=('vapoursynth'
'liblsmash.so'
)
makedepends=('git'
- 'libavresample'
+ 'meson'
)
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
-source=("${_plug}::git+https://github.com/VFR-maniac/L-SMASH-Works.git"
- 'patch.patch'
- )
-sha256sums=('SKIP'
- 'cb9603da5bd264ae5a1917490069d5dd564714bc0bd8aa5c46ad5b7f269170e1'
- )
+source=("${_plug}::git+https://github.com/HolyWu/L-SMASH-Works.git")
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
@@ -34,25 +30,19 @@ pkgver() {
}
prepare() {
- cd "${_plug}"
-
- rm -fr VapourSynth/VapourSynth.h
+ mkdir -p build
- patch --binary -p1 -i "${srcdir}/patch.patch"
+ rm -fr "${_plug}/include/"V*
}
build() {
- cd "${_plug}/VapourSynth"
- ./configure \
- --prefix=/usr \
- --extra-cflags="${CFLAGS} ${CPPFLAGS} $(pkg-config --cflags vapoursynth)" \
- --extra-ldflags="${LDFLAGS}"
+ cd build
- LC_ALL=C make
+ arch-meson "../${_plug}/VapourSynth"
}
package(){
- cd "${_plug}/VapourSynth"
- make DESTDIR="${pkgdir}" install
- install -Dm644 README "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
+ DESTDIR="${pkgdir}" ninja -C build install
+
+ install -Dm644 "${_plug}/AviSynth/README" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
}
diff --git a/patch.patch b/patch.patch
deleted file mode 100644
index ce4ef8a93e93..000000000000
--- a/patch.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-
-diff --git a/common/libavsmash.c b/common/libavsmash.c
-index dacd63a..b7b4a56 100644
---- a/common/libavsmash.c
-+++ b/common/libavsmash.c
-@@ -83,9 +83,6 @@ lsmash_root_t *libavsmash_open_file
- strcpy( error_string, "The number of tracks equals 0.\n" );
- goto open_fail;
- }
-- /* libavformat */
-- av_register_all();
-- avcodec_register_all();
- if( avformat_open_input( p_format_ctx, file_name, NULL, NULL ) )
- {
- strcpy( error_string, "Failed to avformat_open_input.\n" );
-diff --git a/common/lwindex.c b/common/lwindex.c
-index 234e14a..91e7c5f 100644
---- a/common/lwindex.c
-+++ b/common/lwindex.c
-@@ -3229,8 +3229,6 @@ int lwlibav_construct_index
- {
- /* Opening and parsing the index file succeeded. */
- fclose( index );
-- av_register_all();
-- avcodec_register_all();
- lwhp->threads = opt->threads;
- return 0;
- }
-@@ -3246,8 +3244,6 @@ int lwlibav_construct_index
- if( has_lwi_ext )
- lwhp->file_path[file_path_length - 4] = '\0';
- }
-- av_register_all();
-- avcodec_register_all();
- AVFormatContext *format_ctx = NULL;
- if( lavf_open_file( &format_ctx, lwhp->file_path, lhp ) )
- {
-diff --git a/common/osdep.c b/common/osdep.c
-index d81e47f..a6900fe 100644
---- a/common/osdep.c
-+++ b/common/osdep.c
-@@ -65,3 +65,5 @@ FILE *lw_win32_fopen( const char *name, const char *mode )
- }
-
- #endif
-+
-+typedef int make_iso_compilers_happy;
-diff --git a/VapourSynth/video_output.c b/VapourSynth/video_output.c
-index 4599863..45a1fb0 100644
---- a/VapourSynth/video_output.c
-+++ b/VapourSynth/video_output.c
-@@ -20,7 +20,7 @@
-
- /* This file is available under an ISC license. */
-
--#include <string.h>
-+#include <strings.h>
-
- /* Libav */
- #include <libavcodec/avcodec.h> /* Decoder */