summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-04-14 22:01:29 +0200
committersL1pKn072019-04-14 22:02:36 +0200
commitaff79889d59dd9377fdc84f820e62fe697852270 (patch)
treefe25bded7dc58209a962efff8c29b90394cad7c8
parent011c240f1533227e497553f751e11518d6adbe0e (diff)
downloadaur-aff79889d59dd9377fdc84f820e62fe697852270.tar.gz
bump
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD12
-rw-r--r--patch.patch60
4 files changed, 73 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8dc006aed6b9..2a90f68e49f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Apr 8 17:12:16 UTC 2019
+# Sun Apr 14 20:01:23 UTC 2019
pkgbase = vapoursynth-plugin-lsmashsource-git
pkgdesc = Plugin for Vapoursynth: lsmashsource (GIT version)
pkgver = r935.3edd194
@@ -18,7 +18,9 @@ pkgbase = vapoursynth-plugin-lsmashsource-git
provides = vapoursynth-plugin-lsmashsource
conflicts = vapoursynth-plugin-lsmashsource
source = lsmashsource::git+https://github.com/VFR-maniac/L-SMASH-Works.git
+ source = patch.patch
sha256sums = SKIP
+ sha256sums = cb9603da5bd264ae5a1917490069d5dd564714bc0bd8aa5c46ad5b7f269170e1
pkgname = vapoursynth-plugin-lsmashsource-git
diff --git a/.gitignore b/.gitignore
index 05c6d4d4c97b..8a2e0bc8bce4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@
!.gitignore
!.SRCINFO
!PKGBUILD
+patch.patch
diff --git a/PKGBUILD b/PKGBUILD
index 9f564636b70a..27b6d349d966 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -20,8 +20,12 @@ makedepends=('git'
)
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
-source=("${_plug}::git+https://github.com/VFR-maniac/L-SMASH-Works.git")
-sha256sums=('SKIP')
+source=("${_plug}::git+https://github.com/VFR-maniac/L-SMASH-Works.git"
+ 'patch.patch'
+ )
+sha256sums=('SKIP'
+ 'cb9603da5bd264ae5a1917490069d5dd564714bc0bd8aa5c46ad5b7f269170e1'
+ )
pkgver() {
cd "${_plug}"
@@ -33,6 +37,8 @@ prepare() {
cd "${_plug}"
rm -fr VapourSynth/VapourSynth.h
+
+ patch --binary -p1 -i "${srcdir}/patch.patch"
}
build() {
@@ -42,7 +48,7 @@ build() {
--extra-cflags="${CFLAGS} ${CPPFLAGS} $(pkg-config --cflags vapoursynth)" \
--extra-ldflags="${LDFLAGS}"
- make
+ LC_ALL=C make
}
package(){
diff --git a/patch.patch b/patch.patch
new file mode 100644
index 000000000000..ce4ef8a93e93
--- /dev/null
+++ b/patch.patch
@@ -0,0 +1,60 @@
+
+diff --git a/common/libavsmash.c b/common/libavsmash.c
+index dacd63a..b7b4a56 100644
+--- a/common/libavsmash.c
++++ b/common/libavsmash.c
+@@ -83,9 +83,6 @@ lsmash_root_t *libavsmash_open_file
+ strcpy( error_string, "The number of tracks equals 0.\n" );
+ goto open_fail;
+ }
+- /* libavformat */
+- av_register_all();
+- avcodec_register_all();
+ if( avformat_open_input( p_format_ctx, file_name, NULL, NULL ) )
+ {
+ strcpy( error_string, "Failed to avformat_open_input.\n" );
+diff --git a/common/lwindex.c b/common/lwindex.c
+index 234e14a..91e7c5f 100644
+--- a/common/lwindex.c
++++ b/common/lwindex.c
+@@ -3229,8 +3229,6 @@ int lwlibav_construct_index
+ {
+ /* Opening and parsing the index file succeeded. */
+ fclose( index );
+- av_register_all();
+- avcodec_register_all();
+ lwhp->threads = opt->threads;
+ return 0;
+ }
+@@ -3246,8 +3244,6 @@ int lwlibav_construct_index
+ if( has_lwi_ext )
+ lwhp->file_path[file_path_length - 4] = '\0';
+ }
+- av_register_all();
+- avcodec_register_all();
+ AVFormatContext *format_ctx = NULL;
+ if( lavf_open_file( &format_ctx, lwhp->file_path, lhp ) )
+ {
+diff --git a/common/osdep.c b/common/osdep.c
+index d81e47f..a6900fe 100644
+--- a/common/osdep.c
++++ b/common/osdep.c
+@@ -65,3 +65,5 @@ FILE *lw_win32_fopen( const char *name, const char *mode )
+ }
+
+ #endif
++
++typedef int make_iso_compilers_happy;
+diff --git a/VapourSynth/video_output.c b/VapourSynth/video_output.c
+index 4599863..45a1fb0 100644
+--- a/VapourSynth/video_output.c
++++ b/VapourSynth/video_output.c
+@@ -20,7 +20,7 @@
+
+ /* This file is available under an ISC license. */
+
+-#include <string.h>
++#include <strings.h>
+
+ /* Libav */
+ #include <libavcodec/avcodec.h> /* Decoder */