summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-10-19 22:43:45 +0200
committerGustavo Alvarez2016-10-19 22:43:45 +0200
commit2fdff17e111daaaf0d636280e1454fe0e9551733 (patch)
tree5222febd4fc02cdcfb194636a0fd0f4733c4c736
parent9da1cf32b48d6f5ec8d3e7c7a4aad6b87035b7c2 (diff)
downloadaur-2fdff17e111daaaf0d636280e1454fe0e9551733.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6f7c78113900..13fe5c3e3309 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Wed Oct 19 20:43:41 UTC 2016
pkgbase = vapoursynth-plugin-maskdetail-git
pkgdesc = Plugin for Vapoursynth: maskdetail (GIT version)
- pkgver = r8.2af7b11
+ pkgver = r10.1f927c8
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=171546
arch = i686
@@ -11,7 +13,7 @@ pkgbase = vapoursynth-plugin-maskdetail-git
provides = vapoursynth-plugin-maskdetail
conflicts = vapoursynth-plugin-maskdetail
source = maskdetail::git+https://github.com/MonoS/VS-MaskDetail.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-maskdetail-git
diff --git a/PKGBUILD b/PKGBUILD
index 548232d2f1a5..4ab3a99e7d5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=maskdetail
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r8.2af7b11
+pkgver=r10.1f927c8
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
@@ -13,15 +13,19 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/MonoS/VS-MaskDetail.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
-_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
pkgver() {
cd "${_plug}"
+ #echo "$(git describe --long --tags)"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package(){
- install -Dm644 "${_plug}/MaskDetail.py" "${pkgdir}${_sites_packages}/maskdetail.py"
+ install -Dm644 "${_plug}/MaskDetail.py" "${pkgdir}${_site_packages}/MaskDetail.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/MaskDetail.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/MaskDetail.py"
+
}