summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:35:30 +0200
committersl1pkn072015-06-08 20:35:30 +0200
commit9da1cf32b48d6f5ec8d3e7c7a4aad6b87035b7c2 (patch)
tree24203478743db0d362b6fa267b24fb02f411d0fe
downloadaur-9da1cf32b48d6f5ec8d3e7c7a4aad6b87035b7c2.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f7c78113900
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-maskdetail-git
+ pkgdesc = Plugin for Vapoursynth: maskdetail (GIT version)
+ pkgver = r8.2af7b11
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=171546
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-maskdetail
+ conflicts = vapoursynth-plugin-maskdetail
+ source = maskdetail::git+https://github.com/MonoS/VS-MaskDetail.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-maskdetail-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..548232d2f1a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=maskdetail
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r8.2af7b11
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url='http://forum.doom9.org/showthread.php?t=171546'
+license=('LGPL2.1')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/MonoS/VS-MaskDetail.git")
+sha1sums=('SKIP')
+
+_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package(){
+ install -Dm644 "${_plug}/MaskDetail.py" "${pkgdir}${_sites_packages}/maskdetail.py"
+}