summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072018-08-03 00:54:33 +0200
committersL1pKn072018-08-03 00:54:33 +0200
commit5be528930e22f4736d5756bcbb9136ac4cf839c2 (patch)
tree504521883ed08e1b678b1a3b1c1499570639a445
downloadaur-5be528930e22f4736d5756bcbb9136ac4cf839c2.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD42
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08e111388498
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Aug 2 22:54:33 UTC 2018
+pkgbase = vapoursynth-plugin-minideen-git
+ pkgdesc = Plugin for Vapoursynth: minideen (GIT version)
+ pkgver = v1.3.g0355cff
+ pkgrel = 1
+ url = https://github.com/dubhater/vapoursynth-minideen
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = meson
+ depends = vapoursynth
+ provides = vapoursynth-plugin-minideen
+ conflicts = vapoursynth-plugin-minideen
+ source = minideen::git+https://github.com/dubhater/vapoursynth-minideen.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-minideen-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a813b21df95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=minideen
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v1.3.g0355cff
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url="https://github.com/dubhater/vapoursynth-${_plug}"
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git'
+ 'meson'
+ )
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+
+ cd build
+ arch-meson "../${_plug}" \
+ --libdir /usr/lib/vapoursynth
+
+}
+
+build() {
+ ninja -C build
+}
+
+package(){
+ DESTDIR="${pkgdir}" ninja -C build install
+ install -Dm644 "${_plug}/readme.rst" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
+}
+