summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh Holmer2021-10-02 19:21:35 -0400
committerJosh Holmer2021-10-02 19:21:35 -0400
commit9f32d83647d7eb66664abb25a17433b7be75344a (patch)
treecaa850e25fc41ca29fdc3fb4d076c163e400823b
downloadaur-9f32d83647d7eb66664abb25a17433b7be75344a.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD39
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0922f1ff08e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-misc-git
+ pkgdesc = Plugin for Vapoursynth: misc (GIT version)
+ pkgver = R1.2.ged56d96
+ pkgrel = 1
+ url = https://github.com/vapoursynth/misc
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ depends = vapoursynth
+ provides = vapoursynth-plugin-misc
+ conflicts = vapoursynth-plugin-misc
+ source = misc::git+https://github.com/vapoursynth/misc.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-misc-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bcdf393ede8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Joshua Holmer <jholmer.in@gmail.com>
+
+_plug=misc
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=R2.0.gd945b6b
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='https://github.com/vapoursynth/vs-miscfilters-obsolete'
+license=('MIT')
+depends=('vapoursynth')
+makedepends=('git'
+ 'meson'
+)
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/vapoursynth/vs-miscfilters-obsolete.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+ mkdir -p include
+ curl -o "include/filtershared.h" https://raw.githubusercontent.com/vapoursynth/vapoursynth/R56/src/core/filtershared.h
+}
+
+build() {
+ gcc -I/usr/include/vapoursynth -I./include -c -Wall -fPIC ${CXXFLAGS} -o build/miscfilters.o "${_plug}/src/miscfilters.cpp"
+ gcc -L/usr/lib -shared ${LDFLAGS} -o build/libmiscfilters.so build/miscfilters.o
+}
+
+package() {
+ install -Dm644 build/libmiscfilters.so "${pkgdir}/usr/lib/vapoursynth/${_plug}.so"
+ install -Dm644 "${_plug}/docs/misc.rst" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.rst"
+}