summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-12-25 22:24:21 +0100
committersl1pkn072015-12-25 22:24:21 +0100
commitac3a07778c2209e37341c1417ba4e37927d1a654 (patch)
treed7eb4a59258a85e5e0944da4e51ad34f1a947e1b
parent34131e612da9595388691d098cff98d0884781b2 (diff)
downloadaur-ac3a07778c2209e37341c1417ba4e37927d1a654.tar.gz
update PKGBUILD
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD23
2 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c6ba4227591..6856271ad802 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Fri Dec 25 21:23:51 UTC 2015
pkgbase = vapoursynth-plugin-msmoosh-git
pkgdesc = Plugin for Vapoursynth: msmoosh (GIT version)
- pkgver = v1.0.0.ged7687e
+ pkgver = v1.1.0.ge5a7221
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=171159
arch = i686
@@ -11,7 +13,7 @@ pkgbase = vapoursynth-plugin-msmoosh-git
provides = vapoursynth-plugin-msmoosh
conflicts = vapoursynth-plugin-msmoosh
source = msmoosh::git+https://github.com/dubhater/vapoursynth-msmoosh.git
- md5sums = SKIP
+ sha1sums = SKIP
pkgname = vapoursynth-plugin-msmoosh-git
diff --git a/PKGBUILD b/PKGBUILD
index 8df17bc0845b..f32d81f4d594 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,34 +2,37 @@
_plug=msmoosh
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v1.0.0.ged7687e
+pkgver=v1.1.0.ge5a7221
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
-url="http://forum.doom9.org/showthread.php?t=171159"
+url='http://forum.doom9.org/showthread.php?t=171159'
license=('GPL')
depends=('vapoursynth')
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
-md5sums=('SKIP')
-_gitname="${_plug}"
+sha1sums=('SKIP')
pkgver() {
- cd "${_gitname}"
+ cd "${_plug}"
echo "$(git describe --long --tags | tr - .)"
}
-build() {
- cd "${_gitname}"
+prepare() {
+ cd "${_plug}"
./autogen.sh
- ./configure --prefix=/usr --libdir=/usr/lib/vapoursynth
+}
+
+build() {
+ cd "${_plug}"
+ ./configure --libdir=/usr/lib/vapoursynth
make
}
package(){
- cd "${_gitname}"
+ cd "${_plug}"
make DESTDIR="${pkgdir}" install
- install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
+ install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.rst"
}