summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-10-10 02:21:40 +0200
committersL1pKn072021-10-10 02:21:40 +0200
commit01125a07a09d0d014edffa7364b689bb133ea8f4 (patch)
tree579845a22b1604745ef760a172b1cddc1da4e679
downloadaur-01125a07a09d0d014edffa7364b689bb133ea8f4.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..914833f976c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = vapoursynth-plugin-mvmulti
+ pkgdesc = Plugin for Vapoursynth: mvmulti (GIT version)
+ pkgver = r9
+ pkgrel = 1
+ url = https://github.com/IFeelBloated/vapoursynth-mvtools-sf/tree/r9
+ arch = x86_64
+ license = GPL
+ depends = vapoursynth-plugin-mvtools_sf-git
+ source = https://raw.githubusercontent.com/IFeelBloated/vapoursynth-mvtools-sf/r9/src/mvmulti.py
+ sha256sums = 97ead4d5dee3f9a8a3fca31cadc1978f5cacf442c78bf198c84ab5de1e277dc2
+
+pkgname = vapoursynth-plugin-mvmulti
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fc202985aa50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=mvmulti
+pkgname=vapoursynth-plugin-${_plug}
+pkgver=r9
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url="https://github.com/IFeelBloated/vapoursynth-mvtools-sf/tree/r9"
+license=('GPL')
+depends=('vapoursynth-plugin-mvtools_sf-git')
+source=('https://raw.githubusercontent.com/IFeelBloated/vapoursynth-mvtools-sf/r9/src/mvmulti.py')
+sha256sums=('97ead4d5dee3f9a8a3fca31cadc1978f5cacf442c78bf198c84ab5de1e277dc2')
+
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+package(){
+ install -Dm644 "${_plug}.py" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+}