summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-10-07 17:19:47 +0200
committersl1pkn072015-10-07 17:19:47 +0200
commitedba2035c4f3fe6a78245deb5c282416e44f6a1c (patch)
tree38c720f153e850690417dc4910c739bffe86a798
downloadaur-edba2035c4f3fe6a78245deb5c282416e44f6a1c.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..10f4eb8edc7c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-mvsfunc-git
+ pkgdesc = Plugin for Vapoursynth: mvsfunc (GIT version)
+ pkgver = r15.6ea23dd
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=172564
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-mvsfunc
+ conflicts = vapoursynth-plugin-mvsfunc
+ source = mvsfunc::git+https://github.com/HomeOfVapourSynthEvolution/mvsfunc.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-mvsfunc-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ce42743a2883
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=mvsfunc
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r15.6ea23dd
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url='http://forum.doom9.org/showthread.php?t=172564'
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/mvsfunc.git")
+sha1sums=('SKIP')
+
+_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ #echo "$(git describe --long --tags | tr - .)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_plug}"
+ install -Dm644 "${_plug}.py" "${pkgdir}${_sites_packages}/${_plug}.py"
+}