summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:35:47 +0200
committersl1pkn072015-06-08 20:35:47 +0200
commit54b8e8c1f7fffd218fa24729cee16ea31701724e (patch)
treea8293b08e7ec1d1e99b768ab1e9f7e40d738d177
downloadaur-54b8e8c1f7fffd218fa24729cee16ea31701724e.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73b833e4016d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = vapoursynth-plugin-nnedi3-git
+ pkgdesc = Plugin for Vapoursynth: nnedi3 (GIT version)
+ pkgver = v5.4.g7c9348f
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=166434
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = yasm
+ depends = vapoursynth
+ provides = vapoursynth-plugin-nnedi3
+ conflicts = vapoursynth-plugin-nnedi3
+ source = nnedi3::git+https://github.com/dubhater/vapoursynth-nnedi3.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-nnedi3-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..baed3614bc05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=nnedi3
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v5.4.g7c9348f
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url="http://forum.doom9.org/showthread.php?t=166434"
+license=('GPL2')
+depends=('vapoursynth')
+makedepends=('git' 'yasm')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ cd "${_plug}"
+ ./autogen.sh
+}
+
+build() {
+ cd "${_plug}"
+ ./configure --prefix=/usr --libdir=/usr/lib/vapoursynth
+ make
+}
+
+package(){
+ cd "${_plug}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
+}