summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072020-03-19 08:23:28 +0100
committersL1pKn072020-03-19 08:23:28 +0100
commit686dc53ee43a1cf94431d029e1f7c230331bca0a (patch)
treec4ce62acc7e32cf925f398a88eb67ffe1b21933a
downloadaur-686dc53ee43a1cf94431d029e1f7c230331bca0a.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e11607c43edb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-nnedi3_resamplecl-git
+ pkgdesc = Plugin for Vapoursynth: nnedi3_resamplecl (GIT version)
+ pkgver = r4.75877c8
+ pkgrel = 1
+ url = https://github.com/xyx98/my-vapoursynth-script
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = vapoursynth-plugin-mvsfunc-git
+ depends = vapoursynth-plugin-nnedi3cl-git
+ provides = vapoursynth-plugin-nnedi3_resamplecl
+ conflicts = vapoursynth-plugin-nnedi3_resamplecl
+ source = nnedi3_resamplecl::git+https://github.com/xyx98/my-vapoursynth-script.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-nnedi3_resamplecl-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a2803dbfb3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=nnedi3_resamplecl
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r4.75877c8
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='https://github.com/xyx98/my-vapoursynth-script'
+license=('GPL')
+depends=('vapoursynth-plugin-mvsfunc-git'
+ 'vapoursynth-plugin-nnedi3cl-git'
+ )
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/xyx98/my-vapoursynth-script.git")
+sha256sums=('SKIP')
+
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+# echo "$(git describe --long --tags | tr - .)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package(){
+ cd "${_plug}"
+ install -Dm644 nnedi3_resampleCL.py "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+}