summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072017-09-17 15:33:19 +0200
committersL1pKn072017-09-17 15:33:19 +0200
commit70a64e7d93ea289ae30e21631f10fc9ac9320ce6 (patch)
treedfce8d9c04786374a2c4d9e78619655500eb7773
downloadaur-70a64e7d93ea289ae30e21631f10fc9ac9320ce6.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc62adb05c72
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Sun Sep 17 13:33:19 UTC 2017
+pkgbase = vapoursynth-plugin-nnedi3cl-git
+ pkgdesc = Plugin for Vapoursynth: nnedi3cl (GIT version)
+ pkgver = r1.0.g4b92a9f
+ pkgrel = 1
+ url = https://github.com/HomeOfVapourSynthEvolution/VapourSynth-NNEDI3CL
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = opencl-headers
+ makedepends = boost
+ depends = vapoursynth
+ depends = ocl-icd
+ provides = vapoursynth-plugin-nnedi3cl
+ conflicts = vapoursynth-plugin-nnedi3cl
+ source = nnedi3cl::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-NNEDI3CL.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-nnedi3cl-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2987047e9a04
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=nnedi3cl
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r1.0.g4b92a9f
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url='https://github.com/HomeOfVapourSynthEvolution/VapourSynth-NNEDI3CL'
+license=('GPL2')
+depends=('vapoursynth'
+ 'ocl-icd'
+ )
+makedepends=('git'
+ 'opencl-headers'
+ 'boost'
+ )
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-NNEDI3CL.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ cd "${_plug}"
+ ./autogen.sh
+}
+
+build() {
+ cd "${_plug}"
+ ./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib/vapoursynth
+
+ make
+}
+
+package(){
+ cd "${_plug}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}