summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-09-03 21:17:31 +0200
committerGustavo Alvarez2016-09-03 21:17:31 +0200
commit81e41553d6f3a1cb79fafc2a9517469d74669270 (patch)
treed3a853e70b2d87e86a75f91a410977aed458652e
downloadaur-81e41553d6f3a1cb79fafc2a9517469d74669270.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ac627df7712
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Sep 3 19:17:31 UTC 2016
+pkgbase = vapoursynth-plugin-noisegen-hg
+ pkgdesc = Plugin for Vapoursynth: noisegen (HG version)
+ pkgver = 1.79f0e8e8408e
+ pkgrel = 1
+ url = https://bitbucket.org/James1201/vapoursynth-noisegen
+ arch = i686
+ arch = x86_64
+ license = custom:WTFPL
+ makedepends = mercurial
+ depends = vapoursynth
+ provides = vapoursynth-plugin-noisegen
+ conflicts = vapoursynth-plugin-noisegen
+ source = noisegen::hg+https://bitbucket.org/James1201/vapoursynth-noisegen
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-noisegen-hg
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a85cad6cd200
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=noisegen
+pkgname=vapoursynth-plugin-${_plug}-hg
+pkgver=1.79f0e8e8408e
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (HG version)"
+arch=('i686' 'x86_64')
+url='https://bitbucket.org/James1201/vapoursynth-noisegen'
+license=('custom:WTFPL')
+depends=('vapoursynth')
+makedepends=('mercurial')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::hg+https://bitbucket.org/James1201/vapoursynth-noisegen")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(hg log -r -1 --template '{rev}.{node|short}\n')"
+}
+
+prepare() {
+ cd "${_plug}"
+ chmod +x autogen.sh
+ ./autogen.sh
+}
+
+build() {
+ cd "${_plug}"
+ ./configure \
+ --libdir="/usr/lib/vapoursynth"
+ make
+}
+
+package(){
+ cd "${_plug}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}