summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-06-19 15:28:39 +0200
committerGustavo Alvarez2016-06-19 15:28:39 +0200
commita57481f763c65409a20b15541a391388297d7ec0 (patch)
treeb98a6a2ac549769d258d82cf18e3836f09946abe
downloadaur-a57481f763c65409a20b15541a391388297d7ec0.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b390c958116
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+# Generated by mksrcinfo v8
+# Sun Jun 19 13:28:39 UTC 2016
+pkgbase = vapoursynth-plugin-oyster-git
+ pkgdesc = Plugin for Vapoursynth: oyster (GIT version)
+ pkgver = r51.8a33744
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=173470
+ arch = i686
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = git
+ depends = vapoursynth-plugin-bm3d-git
+ depends = vapoursynth-plugin-knlmeanscl
+ depends = vapoursynth-plugin-fmtconv
+ depends = vapoursynth-plugin-msmoosh-git
+ depends = vapoursynth-plugin-mvtools_sf-git
+ depends = vapoursynth-plugin-nnedi3-git
+ provides = vapoursynth-plugin-oyster
+ conflicts = vapoursynth-plugin-oyster
+ source = oyster::git+https://github.com/IFeelBloated/Oyster.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-oyster-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..76ab5dba4250
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=oyster
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r51.8a33744
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url='http://forum.doom9.org/showthread.php?t=173470'
+license=('LGPL2.1')
+depends=('vapoursynth-plugin-bm3d-git'
+ 'vapoursynth-plugin-knlmeanscl'
+ 'vapoursynth-plugin-fmtconv'
+ 'vapoursynth-plugin-msmoosh-git'
+ 'vapoursynth-plugin-mvtools_sf-git'
+ 'vapoursynth-plugin-nnedi3-git'
+ )
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/IFeelBloated/Oyster.git")
+sha1sums=('SKIP')
+
+_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ #echo "$(git describe --long --tags | tr - .)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package(){
+ cd "${_plug}"
+ install -Dm644 Oyster.py "${pkgdir}${_sites_packages}/Oyster.py"
+}