summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDave2020-05-21 16:29:10 -0400
committerDave2020-05-21 16:29:10 -0400
commit61963b792c923789f61d98c4ddb5fa0d056b8bfb (patch)
treea92b83c6dd5a213b5e281591a1fe1792e7380097
downloadaur-61963b792c923789f61d98c4ddb5fa0d056b8bfb.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD52
2 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82e0458f4829
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = vapoursynth-plugin-placebo-git
+ pkgdesc = Plugin for VapourSynth: placebo (GIT version)
+ pkgver = r45.a9d6662
+ pkgrel = 1
+ url = https://github.com/Lypheo/vs-placebo
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ makedepends = meson
+ makedepends = vulkan-headers
+ makedepends = libplacebo
+ depends = vapoursynth
+ provides = vapoursynth-plugin-placebo
+ conflicts = vapoursynth-plugin-placebo
+ source = placebo::git+https://github.com/Lypheo/vs-placebo.git
+ source = libp2p::git+https://github.com/sekrit-twc/libp2p.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-placebo-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bd85d940c86e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Dave <orangechannel@pm.me>
+
+_plug=placebo
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r45.a9d6662
+pkgrel=1
+pkgdesc="Plugin for VapourSynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://github.com/Lypheo/vs-placebo'
+license=('LGPL')
+depends=('vapoursynth')
+makedepends=('git' 'meson' 'vulkan-headers' 'libplacebo')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/Lypheo/vs-placebo.git"
+ "libp2p::git+https://github.com/sekrit-twc/libp2p.git"
+ )
+sha256sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mv libp2p "${_plug}" # this should be done with submodules but I cant get it to work just yet
+ cd "${_plug}"
+# git submodule init
+# git config submodule.libp2p.url "${_plug}/libp2p"
+# git submodule update
+
+ arch-meson builddir
+}
+
+build() {
+ cd "${_plug}"
+ ninja -C builddir
+}
+
+# check() {
+# cd "${_plug}"
+# ninja -C builddir check # is this deprecated??
+# }
+
+package(){
+ cd "${_plug}"
+
+ DESTDIR="${pkgdir}" ninja -C builddir install
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}