summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-08-17 23:56:35 +0200
committerGustavo Alvarez2016-08-17 23:56:35 +0200
commit02bc7d624f5152dbad63990676cfa6c9b2163677 (patch)
tree989bd9b646f2770af27ed2bd176e748c8ffad4fc
downloadaur-02bc7d624f5152dbad63990676cfa6c9b2163677.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1475c8c48d4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Wed Aug 17 21:56:35 UTC 2016
+pkgbase = vapoursynth-plugin-plum-git
+ pkgdesc = Plugin for Vapoursynth: plum (GIT version)
+ pkgver = r6.cc0ff14
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=173775
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth-plugin-knlmeanscl
+ depends = vapoursynth-plugin-fmtconv
+ depends = vapoursynth-plugin-nnedi3-git
+ depends = vapoursynth-plugin-vcfreq
+ depends = vapoursynth-plugin-mvtools_sf-git
+ depends = vapoursynth-plugin-dfttest-git
+ depends = vapoursynth-plugin-bm3d-git
+ provides = vapoursynth-plugin-plum
+ conflicts = vapoursynth-plugin-plum
+ source = plum::git+https://github.com/IFeelBloated/Plum.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-plum-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6923f0a1666b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=plum
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r6.cc0ff14
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url='http://forum.doom9.org/showthread.php?t=173775'
+license=('GPL')
+depends=('vapoursynth-plugin-knlmeanscl'
+ 'vapoursynth-plugin-fmtconv'
+ 'vapoursynth-plugin-nnedi3-git'
+ 'vapoursynth-plugin-vcfreq'
+ 'vapoursynth-plugin-mvtools_sf-git'
+ 'vapoursynth-plugin-dfttest-git'
+ 'vapoursynth-plugin-bm3d-git'
+ )
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/IFeelBloated/Plum.git")
+sha1sums=('SKIP')
+
+_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ #echo "$(git describe --long --tags | tr - .)"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package(){
+ cd "${_plug}"
+ install -Dm644 Plum.py "${pkgdir}${_sites_packages}/Plum.py"
+}