summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-10-19 22:15:38 +0200
committerGustavo Alvarez2016-10-19 22:15:38 +0200
commita823c0406d2b1098224abcc49e5912b5407a1253 (patch)
treed3ff622ed589cc91e93a44e970d6da12919c4832
parent02bc7d624f5152dbad63990676cfa6c9b2163677 (diff)
downloadaur-a823c0406d2b1098224abcc49e5912b5407a1253.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1475c8c48d4a..91ddd23d3b4a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Aug 17 21:56:35 UTC 2016
+# Wed Oct 19 20:15:33 UTC 2016
pkgbase = vapoursynth-plugin-plum-git
pkgdesc = Plugin for Vapoursynth: plum (GIT version)
- pkgver = r6.cc0ff14
+ pkgver = r9.9602bec
pkgrel = 1
url = http://forum.doom9.org/showthread.php?t=173775
arch = i686
@@ -19,7 +19,7 @@ pkgbase = vapoursynth-plugin-plum-git
provides = vapoursynth-plugin-plum
conflicts = vapoursynth-plugin-plum
source = plum::git+https://github.com/IFeelBloated/Plum.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-plum-git
diff --git a/PKGBUILD b/PKGBUILD
index 6923f0a1666b..1c4179817579 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=plum
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r6.cc0ff14
+pkgver=r9.9602bec
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
@@ -20,9 +20,9 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/IFeelBloated/Plum.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
-_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
pkgver() {
cd "${_plug}"
@@ -32,5 +32,7 @@ pkgver() {
package(){
cd "${_plug}"
- install -Dm644 Plum.py "${pkgdir}${_sites_packages}/Plum.py"
+ install -Dm644 Plum.py "${pkgdir}${_site_packages}/Plum.py"
+ python -m compileall -q -f -d "${_sites_packages}" "${pkgdir}${_site_packages}/Plum.py"
+ python -OO -m compileall -q -f -d "${_sites_packages}" "${pkgdir}${_site_packages}/Plum.py"
}