summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-10-25 21:36:52 +0200
committersL1pKn072021-10-25 21:36:52 +0200
commit1b3912f516b3a5cebd30df899624671697b347bd (patch)
tree216a92ea708914895ebc7302faa52bb3e36d8908
parentc584a8ba92933c1247697b9ef934784ce616d456 (diff)
downloadaur-1b3912f516b3a5cebd30df899624671697b347bd.tar.gz
bump
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b359921f418f..a78d388473c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = vapoursynth-plugin-pvsfunc-git
license = GPL
makedepends = git
makedepends = python-poetry
+ makedepends = python-pip
depends = vapoursynth-plugin-havsfunc-git
depends = vapoursynth-plugin-pyd2v-git
depends = python-pymediainfo
diff --git a/PKGBUILD b/PKGBUILD
index 9d0a8284bf99..ab6f418235b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,6 +15,7 @@ depends=('vapoursynth-plugin-havsfunc-git'
)
makedepends=('git'
'python-poetry'
+ 'python-pip'
)
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
@@ -34,4 +35,9 @@ build() {
package() {
cd "${_plug}"
pip install -I --root "${pkgdir}" --no-warn-script-location --no-deps dist/*.whl
+
+ rm -fr "${pkgdir}${_site_packages}"/{README.md,LICENSE}
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}