summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072023-05-05 00:16:40 +0200
committersL1pKn072023-05-05 00:16:40 +0200
commitd7803c042d5357a3d37109b1ec017e812bbfe8af (patch)
tree4d017a21b0a46d33d9dda03f0183a53d1d0fdd8e
parent1414b5c9ea05d38c3f13ca7a6921399e18f06541 (diff)
downloadaur-d7803c042d5357a3d37109b1ec017e812bbfe8af.tar.gz
bump
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 849e74273107..29e47a2272f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = vapoursynth-plugin-pvsfunc-git
pkgdesc = Plugin for Vapoursynth: pvsfunc (GIT version)
- pkgver = 4.4.0.1.gf44039e
+ pkgver = 4.4.0.2.g9786659
pkgrel = 1
url = https://forum.doom9.org/showthread.php?t=180426
arch = any
license = GPL
makedepends = git
- makedepends = python-pip
+ makedepends = python-build
+ makedepends = python-wheel
+ makedepends = python-installer
depends = vapoursynth-plugin-havsfunc-git
depends = vapoursynth-plugin-pyd2v-git
depends = python-pymediainfo
diff --git a/PKGBUILD b/PKGBUILD
index d84946703a6d..70a0508f5919 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=pvsfunc
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=4.4.0.1.gf44039e
+pkgver=4.4.0.2.g9786659
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('any')
@@ -14,7 +14,9 @@ depends=('vapoursynth-plugin-havsfunc-git'
'python-more-itertools'
)
makedepends=('git'
- 'python-pip'
+ 'python-build'
+ 'python-wheel'
+ 'python-installer'
)
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
@@ -26,14 +28,18 @@ pkgver() {
echo "$(git describe --long --tags | tr - . | tr -d v)"
}
+prepare() {
+ sed 27d -i "${_plug}/pyproject.toml"
+}
+
build() {
cd "${_plug}"
- pip wheel --no-deps . -w dist
+ python -m build --wheel --no-isolation
}
package() {
cd "${_plug}"
- pip install -I -U --root "${pkgdir}" --no-warn-script-location --no-deps dist/*.whl
+ python -m installer --destdir="${pkgdir}" dist/*.whl
install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}