summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072020-03-06 19:30:46 +0100
committersL1pKn072020-03-06 19:30:46 +0100
commit67464976e3202dc3ae48ebd5e5dac419587cdc28 (patch)
treefb9f784ff425b0ce55cffe8e5926a492aa37eb97
downloadaur-67464976e3202dc3ae48ebd5e5dac419587cdc28.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD31
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..43fbafc15823
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-pyd2v-git
+ pkgdesc = Plugin for Vapoursynth: pyd2v (GIT version)
+ pkgver = v1.0.0.2.r3.635f7b3
+ pkgrel = 1
+ url = https://forum.doom9.org/showthread.php?t=180426
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python-setuptools
+ depends = vapoursynth
+ provides = vapoursynth-plugin-pyd2v
+ conflicts = vapoursynth-plugin-pyd2v
+ source = pyd2v::git+https://github.com/rlaPHOENiX/pyd2v.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-pyd2v-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d597265e4b8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=pyd2v
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v1.0.0.2.r3.635f7b3
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url='https://forum.doom9.org/showthread.php?t=180426'
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git'
+ 'python-setuptools'
+ )
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/rlaPHOENiX/pyd2v.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ _ver="$(cat setup.py | grep -m1 version | grep -o "[[:digit:]]*" | paste -sd'.')"
+ echo "v${_ver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_plug}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}