summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-10-09 15:29:28 +0200
committersL1pKn072019-10-09 15:29:28 +0200
commit4c8db648d8026e4911bbb3bb6b458f2763f5a7c1 (patch)
tree71e66d218a4fbd0b891c277af296879fcc18a8d5
parentd957e767acd081cc6f49864fe032b736dd33f9ac (diff)
downloadaur-4c8db648d8026e4911bbb3bb6b458f2763f5a7c1.tar.gz
bump
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD21
2 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e2be3c68bf91..5a04a8ce0200 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
-# Generated by mksrcinfo v8
-# Sat Mar 2 19:58:15 UTC 2019
pkgbase = vapoursynth-plugin-readmpls-git
pkgdesc = Plugin for Vapoursynth: readmpls (GIT version)
- pkgver = r3.1.g2a0f835
+ pkgver = r4.0.g205f816
pkgrel = 1
url = https://forum.doom9.org/showthread.php?t=174580
arch = x86_64
license = GPL3
makedepends = git
+ makedepends = meson
depends = libbluray.so
depends = vapoursynth
provides = vapoursynth-plugin-readmpls
diff --git a/PKGBUILD b/PKGBUILD
index d704095b6402..a993f54e1e4e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_plug=readmpls
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=r3.1.g2a0f835
+pkgver=r4.0.g205f816
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
@@ -11,7 +11,9 @@ license=('GPL3')
depends=('libbluray.so'
'vapoursynth'
)
-makedepends=('git')
+makedepends=('git'
+ 'meson'
+ )
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-ReadMpls.git")
@@ -24,21 +26,18 @@ pkgver() {
prepare() {
mkdir -p build
-
- cd "${_plug}"
- ./autogen.sh
}
build() {
cd build
- ../"${_plug}"/configure \
- --prefix=/usr \
- --libdir=/usr/lib/vapoursynth
+ arch-meson "../${_plug}" \
+ --buildtype=release \
+ --libdir /usr/lib/vapoursynth
- make
+ ninja
}
package(){
- make -C build DESTDIR="${pkgdir}" install
- install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ DESTDIR="${pkgdir}" ninja -C build install
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
}