summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:54:29 +0200
committersl1pkn072015-06-08 20:54:29 +0200
commit0d8a23a15941f4a71e0460379879d515df109ca5 (patch)
tree7ce93a739cb91fc2e4c92b9c062fea7d331dd400
downloadaur-0d8a23a15941f4a71e0460379879d515df109ca5.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD41
-rw-r--r--removedirtvs.py14
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..111ac9d5b00d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = vapoursynth-plugin-removedirtvs-git
+ pkgdesc = Plugin for Vapoursynth: removedirtvs (GIT version)
+ pkgver = 20131120.ddc78e5
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=169771
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-removedirtvs
+ conflicts = vapoursynth-plugin-removedirtvs
+ source = git+https://github.com/handaimaoh/removedirtvs.git
+ source = removedirtvs.py
+ sha1sums = SKIP
+ sha1sums = bf3826d8944b135c0f32fbfc5e21de35718a2c33
+
+pkgname = vapoursynth-plugin-removedirtvs-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ff1e561c4bed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!removedirtvs.py
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3e501399743
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=removedirtvs
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=20131120.ddc78e5
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url="http://forum.doom9.org/showthread.php?t=169771"
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("git+https://github.com/handaimaoh/${_plug}.git"
+ 'removedirtvs.py')
+sha1sums=('SKIP'
+ 'bf3826d8944b135c0f32fbfc5e21de35718a2c33')
+_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git log -1 --format="%h")"
+}
+
+prepare() {
+ cd "${_plug}"
+ rm VapourSynth.h VSHelper.h
+ echo "all:
+ g++ -shared ${CXXFLAGS} -fPIC -fpermissive -DVS_TARGET_CPU_X86=1 -I. -o lib${_plug}.so *.cpp $(pkg-config --cflags vapoursynth)" > Makefile
+}
+
+build() {
+ cd "${_plug}"
+ make
+}
+
+package(){
+ install -Dm755 "${_plug}/lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
+ install -Dm644 removedirtvs.py "${pkgdir}${_sites_packages}/removedirtvs.py"
+}
diff --git a/removedirtvs.py b/removedirtvs.py
new file mode 100644
index 000000000000..ebfacd11d072
--- /dev/null
+++ b/removedirtvs.py
@@ -0,0 +1,14 @@
+#removedirtvs.py
+
+import vapoursynth as vs
+
+def RemoveDirt(input, repmode=16):
+ core = vs.get_core()
+ cleansed = core.rgvs.Clense(input)
+ sbegin = core.rgvs.ForwardClense(input)
+ send = core.rgvs.BackwardClense(input)
+ scenechange = core.rdvs.SCSelect(input, sbegin, send, cleansed)
+ alt = core.rgvs.Repair(scenechange, input, mode=[repmode,repmode,1])
+ restore = core.rgvs.Repair(cleansed, input, mode=[repmode,repmode,1])
+ corrected = core.rdvs.RestoreMotionBlocks(cleansed, restore, neighbour=input, alternative=alt, gmthreshold=70, dist=1, dmode=2, noise=10, noisy=12, grey=0)
+ return core.rgvs.RemoveGrain(corrected, mode=[17,17,1]) \ No newline at end of file