summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-09-25 18:04:26 +0200
committersl1pkn072015-09-25 18:04:26 +0200
commit6d8e3010791434ef6818b1c5cd64d45db2323f4d (patch)
tree8c16d818360aaf3e69e80760d6224d0f481f1730
parentd8653b2390fb66febbe61954cf7391555ed74306 (diff)
downloadaur-6d8e3010791434ef6818b1c5cd64d45db2323f4d.tar.gz
Add 'vapoursynth-plugin-scoll-git' to depends
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
-rw-r--r--removedirtvs.py14
3 files changed, 3 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86bfc1a5adbb..cb2f1f0d33dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,11 +7,10 @@ pkgbase = vapoursynth-plugin-removedirtvs-git
arch = x86_64
license = GPL
makedepends = git
- depends = vapoursynth
+ depends = vapoursynth-plugin-scoll-git
provides = vapoursynth-plugin-removedirtvs
conflicts = vapoursynth-plugin-removedirtvs
source = git+https://github.com/handaimaoh/removedirtvs.git
- source = removedirtvs.py
sha1sums = SKIP
sha1sums = bf3826d8944b135c0f32fbfc5e21de35718a2c33
diff --git a/PKGBUILD b/PKGBUILD
index 9eb9fc3044b2..d75d5f15c1db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,12 +8,11 @@ pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('i686' 'x86_64')
url='http://forum.doom9.org/showthread.php?t=169771'
license=('GPL')
-depends=('vapoursynth')
+depends=('vapoursynth-plugin-scoll-git')
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
-source=("git+https://github.com/handaimaoh/${_plug}.git"
- 'removedirtvs.py')
+source=("git+https://github.com/handaimaoh/${_plug}.git")
sha1sums=('SKIP'
'bf3826d8944b135c0f32fbfc5e21de35718a2c33')
@@ -38,5 +37,4 @@ build() {
package() {
install -Dm755 "lib${_plug}.so" "${pkgdir}/usr/lib/vapoursynth/lib${_plug}.so"
- install -Dm644 removedirtvs.py "${pkgdir}${_sites_packages}/removedirtvs.py"
}
diff --git a/removedirtvs.py b/removedirtvs.py
deleted file mode 100644
index ebfacd11d072..000000000000
--- a/removedirtvs.py
+++ /dev/null
@@ -1,14 +0,0 @@
-#removedirtvs.py
-
-import vapoursynth as vs
-
-def RemoveDirt(input, repmode=16):
- core = vs.get_core()
- cleansed = core.rgvs.Clense(input)
- sbegin = core.rgvs.ForwardClense(input)
- send = core.rgvs.BackwardClense(input)
- scenechange = core.rdvs.SCSelect(input, sbegin, send, cleansed)
- alt = core.rgvs.Repair(scenechange, input, mode=[repmode,repmode,1])
- restore = core.rgvs.Repair(cleansed, input, mode=[repmode,repmode,1])
- corrected = core.rdvs.RestoreMotionBlocks(cleansed, restore, neighbour=input, alternative=alt, gmthreshold=70, dist=1, dmode=2, noise=10, noisy=12, grey=0)
- return core.rgvs.RemoveGrain(corrected, mode=[17,17,1]) \ No newline at end of file