summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-12-25 22:46:25 +0100
committersl1pkn072015-12-25 22:46:25 +0100
commit966baa4070e368d03853e806d7966dc979e2ae56 (patch)
tree4de3e38a07d603891bb48fa0701e0ba0afb24d97
parent6d8e3010791434ef6818b1c5cd64d45db2323f4d (diff)
downloadaur-966baa4070e368d03853e806d7966dc979e2ae56.tar.gz
update PKGBUILD
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb2f1f0d33dd..49aff54f4366 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Fri Dec 25 21:46:09 UTC 2015
pkgbase = vapoursynth-plugin-removedirtvs-git
pkgdesc = Plugin for Vapoursynth: removedirtvs (GIT version)
pkgver = r78.ddc78e5
@@ -12,7 +14,6 @@ pkgbase = vapoursynth-plugin-removedirtvs-git
conflicts = vapoursynth-plugin-removedirtvs
source = git+https://github.com/handaimaoh/removedirtvs.git
sha1sums = SKIP
- sha1sums = bf3826d8944b135c0f32fbfc5e21de35718a2c33
pkgname = vapoursynth-plugin-removedirtvs-git
diff --git a/PKGBUILD b/PKGBUILD
index d75d5f15c1db..b65dcdff0417 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,8 +13,7 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("git+https://github.com/handaimaoh/${_plug}.git")
-sha1sums=('SKIP'
- 'bf3826d8944b135c0f32fbfc5e21de35718a2c33')
+sha1sums=('SKIP')
_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
@@ -28,7 +27,12 @@ prepare() {
rm -fr "${_plug}/"{VapourSynth,VSHelper}.h
echo "all:
- g++ -o lib${_plug}.so -std=gnu++11 ${CXXFLAGS} ${CPPFLAGS} ${LDFLAGS} $(pkg-config --cflags vapoursynth) ${_plug}/*.cpp -fPIC -shared -fpermissive -DVS_TARGET_CPU_X86=1" > Makefile
+ g++ -c -std=gnu++11 -DVS_TARGET_CPU_X86=1 -fpermissive -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) ${_plug}/DupBlocks.cpp -o DupBlocks.o
+ g++ -c -std=gnu++11 -DVS_TARGET_CPU_X86=1 -fpermissive -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) ${_plug}/RemoveDirt.cpp -o RemoveDirt.o
+ g++ -c -std=gnu++11 -DVS_TARGET_CPU_X86=1 -fpermissive -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) ${_plug}/RestoreMotionBlocks.cpp -o RestoreMotionBlocks.o
+ g++ -c -std=gnu++11 -DVS_TARGET_CPU_X86=1 -fpermissive -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) ${_plug}/SCSelect.cpp -o SCSelect.o
+ g++ -c -std=gnu++11 -DVS_TARGET_CPU_X86=1 -fpermissive -fPIC ${CXXFLAGS} ${CPPFLAGS} -I. $(pkg-config --cflags vapoursynth) ${_plug}/shared.cpp -o shared.o
+ g++ -shared -fPIC ${LDFLAGS} -o lib${_plug}.so DupBlocks.o RemoveDirt.o RestoreMotionBlocks.o SCSelect.o shared.o" > Makefile
}
build() {