summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-03-02 20:58:35 +0100
committersL1pKn072019-03-02 20:58:35 +0100
commitbe21fbef21c190c83dadcc5d7e95bd900f61fbe2 (patch)
treeb71a2ee85484b2bc1fc85b0226e4f2634885ecae
parent7b86ca29f6d966c7b227ae934d8aaa30c449f348 (diff)
downloadaur-be21fbef21c190c83dadcc5d7e95bd900f61fbe2.tar.gz
bump
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef2946e570fd..c757b878d68b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Sat Sep 3 19:22:19 UTC 2016
+# Sat Mar 2 19:58:35 UTC 2019
pkgbase = vapoursynth-plugin-replaceframes-hg
pkgdesc = Plugin for Vapoursynth: replaceframes (HG version)
pkgver = 4.37bd14b3cff3
pkgrel = 1
url = https://bitbucket.org/James1201/vapoursynth-replaceframes
- arch = i686
arch = x86_64
license = custom:WTFPL
makedepends = mercurial
@@ -14,7 +13,7 @@ pkgbase = vapoursynth-plugin-replaceframes-hg
provides = vapoursynth-plugin-replaceframes
conflicts = vapoursynth-plugin-replaceframes
source = replaceframes::hg+https://bitbucket.org/James1201/vapoursynth-replaceframes
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-replaceframes-hg
diff --git a/PKGBUILD b/PKGBUILD
index c70544c17ea8..a9f43c1c2bf7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=vapoursynth-plugin-${_plug}-hg
pkgver=4.37bd14b3cff3
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (HG version)"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://bitbucket.org/James1201/vapoursynth-replaceframes'
license=('custom:WTFPL')
depends=('vapoursynth'
@@ -15,7 +15,7 @@ makedepends=('mercurial')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::hg+https://bitbucket.org/James1201/vapoursynth-replaceframes")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
@@ -23,21 +23,24 @@ pkgver() {
}
prepare() {
+ mkdir -p build
+
cd "${_plug}"
chmod +x autogen.sh
./autogen.sh
}
build() {
- cd "${_plug}"
- ./configure \
+ cd build
+ ../"${_plug}"/configure \
--libdir="/usr/lib/vapoursynth"
+
make
}
package(){
- cd "${_plug}"
- make DESTDIR="${pkgdir}" install
- install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ make -C build DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ install -Dm644 "${_plug}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}