summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:36:08 +0200
committersl1pkn072015-06-08 20:36:08 +0200
commit9980b8a13f5a3b7c95136e9d0364aa2003953783 (patch)
treeb469dbafc7ab8a5f0acc77b9896dd74a0f7b6f5e
downloadaur-9980b8a13f5a3b7c95136e9d0364aa2003953783.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD37
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2d9347a64a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-retinex-git
+ pkgdesc = Plugin for Vapoursynth: retinex (GIT version)
+ pkgver = r3.1.gbd7710b
+ pkgrel = 1
+ url = http://forum.doom9.org/showthread.php?t=171307
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-retinex
+ conflicts = vapoursynth-plugin-retinex
+ source = retinex::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-Retinex.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-retinex-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d8dbd4124f2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=retinex
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r3.1.gbd7710b
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url="http://forum.doom9.org/showthread.php?t=171307"
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-Retinex.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ chmod +x "${_plug}/configure"
+}
+
+build() {
+ cd "${_plug}"
+ ./configure --gcc --install="${pkgdir}/usr/lib/vapoursynth"
+ make
+}
+
+package(){
+ cd "${_plug}"
+ make install
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}