summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072021-10-10 07:20:19 +0200
committersL1pKn072021-10-10 07:20:19 +0200
commitc5acc62e4e2f5739ccf9ce7646c9f1094163da12 (patch)
treef0033e280542520fc36ffb68188886f07ff4986d
downloadaur-c5acc62e4e2f5739ccf9ce7646c9f1094163da12.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD60
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c9c4bf2ce2d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = vapoursynth-plugin-rife-ncnn-vulkan-git
+ pkgdesc = Plugin for Vapoursynth: rife-ncnn-vulkan (GIT version)
+ pkgver = r1.15.gf821053
+ pkgrel = 1
+ url = https://github.com/HomeOfVapourSynthEvolution/VapourSynth-RIFE-ncnn-Vulkan
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ depends = vapoursynth
+ provides = vapoursynth-plugin-rife-ncnn-vulkan
+ conflicts = vapoursynth-plugin-rife-ncnn-vulkan
+ source = rife-ncnn-vulkan::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-RIFE-ncnn-Vulkan.git
+ source = git+https://github.com/Tencent/ncnn.git
+ source = git+https://github.com/KhronosGroup/glslang.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-rife-ncnn-vulkan-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e354abd31144
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=rife-ncnn-vulkan
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r1.15.gf821053
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url='https://github.com/HomeOfVapourSynthEvolution/VapourSynth-RIFE-ncnn-Vulkan'
+license=('MIT')
+depends=('vapoursynth')
+makedepends=('git'
+ 'meson'
+ )
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/HomeOfVapourSynthEvolution/VapourSynth-RIFE-ncnn-Vulkan.git"
+ 'git+https://github.com/Tencent/ncnn.git'
+ 'git+https://github.com/KhronosGroup/glslang.git'
+ )
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ )
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+
+ cd "${_plug}"
+ git config submodule.subprojects/ncnn.url "${srcdir}/ncnn"
+ git submodule update --init subprojects/ncnn
+
+ sed "s|models|${_plug}-models|g" -i RIFE/plugin.cpp
+
+ cd subprojects/ncnn
+ git config submodule.glslang.url "${srcdir}/glslang"
+ git submodule update --init glslang
+}
+
+build() {
+ cd build
+ arch-meson "../${_plug}" \
+ --libdir /usr/lib/vapoursynth
+
+ ninja
+}
+
+package(){
+ DESTDIR="${pkgdir}" ninja -C build install
+
+ mv "${pkgdir}/usr/lib/vapoursynth/models" "${pkgdir}/usr/lib/vapoursynth/${_plug}-models"
+
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ install -Dm644 "${_plug}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}