summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-03-27 19:11:47 +0100
committersL1pKn072019-03-27 19:11:47 +0100
commitf75f4d9df1bcfaee3bcec970512f38e4787c37e2 (patch)
tree8cab857bd9d7d23109524e244c13dc5ec8481444
downloadaur-f75f4d9df1bcfaee3bcec970512f38e4787c37e2.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD43
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b572b37fd520
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Mar 27 18:11:47 UTC 2019
+pkgbase = vapoursynth-plugin-sangnom-git
+ pkgdesc = Plugin for Vapoursynth: sangnom (Fork)(GIT version)
+ pkgver = r41.1.g44b0341
+ pkgrel = 1
+ url = https://github.com/dubhater/vapoursynth-sangnom
+ arch = x86_64
+ license = MIT
+ makedepends = mercurial
+ depends = vapoursynth
+ provides = vapoursynth-plugin-sangnom
+ provides = vapoursynth-plugin-sangnom-hg
+ conflicts = vapoursynth-plugin-sangnom
+ conflicts = vapoursynth-plugin-sangnom-hg
+ source = sangnom::git+https://github.com/dubhater/vapoursynth-sangnom.git
+ sha256sums = SKIP
+
+pkgname = vapoursynth-plugin-sangnom-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f44c303e6cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=sangnom
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r41.1.g44b0341
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (Fork)(GIT version)"
+arch=('x86_64')
+url='https://github.com/dubhater/vapoursynth-sangnom'
+license=('MIT')
+depends=('vapoursynth')
+makedepends=('mercurial')
+provides=("vapoursynth-plugin-${_plug}"
+ "vapoursynth-plugin-${_plug}-hg"
+ )
+conflicts=("vapoursynth-plugin-${_plug}"
+ "vapoursynth-plugin-${_plug}-hg"
+ )
+source=("${_plug}::git+https://github.com/dubhater/vapoursynth-sangnom.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ arch-meson "../${_plug}" \
+ --libdir /usr/lib/vapoursynth
+
+ ninja
+}
+
+package(){
+ DESTDIR="${pkgdir}" ninja -C build install
+
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+}