summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-03-02 20:58:54 +0100
committersL1pKn072019-03-02 20:58:54 +0100
commit28ed48736861f405d2f69bb3b582c0050088ec9d (patch)
treed4b7cf356efb8ae78cd922e50988d50bb6fa3aea
parentc86056d1942616a84d68e07349353f73eb68871f (diff)
downloadaur-28ed48736861f405d2f69bb3b582c0050088ec9d.tar.gz
bump
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD24
2 files changed, 18 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a77a29bc04e..8c564434c0d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Mon Aug 29 13:40:09 UTC 2016
+# Sat Mar 2 19:58:54 UTC 2019
pkgbase = vapoursynth-plugin-sangnom-hg
pkgdesc = Plugin for Vapoursynth: sangnom (HG version)
- pkgver = 36.24bf165026c6
+ pkgver = 40.5a00bb64258d
pkgrel = 1
- url = http://forum.doom9.org/showthread.php?t=173752
- arch = i686
+ url = https://forum.doom9.org/showthread.php?t=173752
arch = x86_64
license = MIT
makedepends = mercurial
@@ -13,7 +12,7 @@ pkgbase = vapoursynth-plugin-sangnom-hg
provides = vapoursynth-plugin-sangnom
conflicts = vapoursynth-plugin-sangnom
source = sangnom::hg+https://bitbucket.org/James1201/vapoursynth-sangnom
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-sangnom-hg
diff --git a/PKGBUILD b/PKGBUILD
index 6fe3dd540175..7fcc319b92b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
_plug=sangnom
pkgname=vapoursynth-plugin-${_plug}-hg
-pkgver=36.24bf165026c6
+pkgver=40.5a00bb64258d
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (HG version)"
-arch=('i686' 'x86_64')
-url='http://forum.doom9.org/showthread.php?t=173752'
+arch=('x86_64')
+url='https://forum.doom9.org/showthread.php?t=173752'
license=('MIT')
depends=('vapoursynth')
makedepends=('mercurial')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::hg+https://bitbucket.org/James1201/vapoursynth-sangnom")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
@@ -21,21 +21,25 @@ pkgver() {
}
prepare() {
+ mkdir -p build
+
cd "${_plug}"
chmod +x autogen.sh
./autogen.sh
}
build() {
- cd "${_plug}"
- ./configure \
+ cd build
+ ../"${_plug}"/configure \
--libdir="/usr/lib/vapoursynth"
+
make
}
package(){
- cd "${_plug}"
- make DESTDIR="${pkgdir}" install
- install -Dm644 README.md "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ make -C build DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${_plug}/README.md" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README.md"
+ install -Dm644 "${_plug}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}