summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:36:30 +0200
committersl1pkn072015-06-08 20:36:30 +0200
commit1aaea60dadcbd3e6375e9e82f6474ac6a1cb735d (patch)
tree73fb3645bb41f61ff5d39fd87f717f27ced1c9ab
downloadaur-1aaea60dadcbd3e6375e9e82f6474ac6a1cb735d.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD35
3 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0eb6f5ff766b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-scxvid-git
+ pkgdesc = Plugin for Vapoursynth: scxvid (GIT version)
+ pkgver = v1.0.ge9deca0
+ pkgrel = 1
+ url = https://github.com/dubhater/vapoursynth-scxvid
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ provides = vapoursynth-plugin-scxvid
+ conflicts = vapoursynth-plugin-scxvid
+ source = scxvid::git+https://github.com/dubhater/vapoursynth-scxvid.git
+ md5sums = SKIP
+
+pkgname = vapoursynth-plugin-scxvid-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f04e581f80c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=scxvid
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v1.0.ge9deca0
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('i686' 'x86_64')
+url="https://github.com/dubhater/vapoursynth-${_plug}"
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
+md5sums=('SKIP')
+_gitname="${_plug}"
+
+pkgver() {
+ cd "${_gitname}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+build() {
+ cd "${_gitname}"
+ ./autogen.sh
+ ./configure --prefix=/usr --libdir=/usr/lib/vapoursynth
+ make
+}
+
+package(){
+ cd "${_gitname}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/README"
+}