summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072019-03-02 20:59:13 +0100
committersL1pKn072019-03-02 20:59:13 +0100
commit35dcc27d212887fea684d4bb089dba1d36a43da3 (patch)
tree1cb394ad1f3a2696f89b48d550351a0ecc229a4b
parent9b1c03e3b711976634aeec56f24b176aff2edd8c (diff)
downloadaur-35dcc27d212887fea684d4bb089dba1d36a43da3.tar.gz
bump
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD21
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 80af90899dce..e664135f0269 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
# Generated by mksrcinfo v8
-# Fri Dec 25 22:02:47 UTC 2015
+# Sat Mar 2 19:59:13 UTC 2019
pkgbase = vapoursynth-plugin-scxvid-git
pkgdesc = Plugin for Vapoursynth: scxvid (GIT version)
- pkgver = v1.0.ge9deca0
+ pkgver = v1.1.g48817c0
pkgrel = 1
url = https://github.com/dubhater/vapoursynth-scxvid
- arch = i686
arch = x86_64
license = GPL
makedepends = git
@@ -13,7 +12,7 @@ pkgbase = vapoursynth-plugin-scxvid-git
provides = vapoursynth-plugin-scxvid
conflicts = vapoursynth-plugin-scxvid
source = scxvid::git+https://github.com/dubhater/vapoursynth-scxvid.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-scxvid-git
diff --git a/PKGBUILD b/PKGBUILD
index 645b260aca98..85bace29c18b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,10 +2,10 @@
_plug=scxvid
pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v1.0.ge9deca0
+pkgver=v1.1.g48817c0
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/dubhater/vapoursynth-${_plug}"
license=('GPL')
depends=('vapoursynth')
@@ -13,7 +13,7 @@ makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "${_plug}"
@@ -21,18 +21,23 @@ pkgver() {
}
prepare() {
+ mkdir -p build
+
cd "${_plug}"
./autogen.sh
}
build() {
- cd "${_plug}"
- ./configure --libdir=/usr/lib/vapoursynth
+ cd build
+ ../"${_plug}"/configure \
+ --prefix=/usr \
+ --libdir=/usr/lib/vapoursynth
+
make
}
package(){
- cd "${_plug}"
- make DESTDIR="${pkgdir}" install
- install -Dm644 readme.rst "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
+ make -C build DESTDIR="${pkgdir}" install
+
+ install -Dm644 "${_plug}/readme.rst" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
}