summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsl1pkn072015-06-08 20:56:34 +0200
committersl1pkn072015-06-08 20:56:34 +0200
commit63623fe8c03b9c59be9d177364b9eef5b215c16d (patch)
treed528bfe4ae10efb247e4bcf1ef2a63f4f46b7422
downloadaur-63623fe8c03b9c59be9d177364b9eef5b215c16d.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66e7f5add008
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = vapoursynth-plugin-sharpaamcmod-git
+ pkgdesc = Plugin for Vapoursynth: sharpaamcmod (GIT version)
+ pkgver = r4
+ pkgrel = 1
+ url = https://gist.github.com/4re
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = vapoursynth
+ depends = vapoursynth-plugin-havsfunc
+ provides = vapoursynth-plugin-sharpaamcmod
+ conflicts = vapoursynth-plugin-sharpaamcmod
+ source = sharpaamcmod::git+https://gist.github.com/8fee7aa32ba9ac566ed0.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-sharpaamcmod-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca7bd937337b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=sharpaamcmod
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=r4
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('any')
+url="https://gist.github.com/4re"
+license=('GPL')
+depends=('vapoursynth' 'vapoursynth-plugin-havsfunc')
+makedepends=('git')
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://gist.github.com/8fee7aa32ba9ac566ed0.git")
+sha1sums=('SKIP')
+_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+
+pkgver() {
+ cd "${_plug}"
+ printf "r%s" "$(git rev-list --count HEAD)"
+}
+
+package() {
+ install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_sites_packages}/${_plug}.py"
+}