summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGustavo Alvarez2016-10-19 22:55:53 +0200
committerGustavo Alvarez2016-10-19 22:55:53 +0200
commitcc42a10be90b1cf0b1837cdf74f3246c6058ccb1 (patch)
treec69fe1e341e0fd22b2ace52b006b5ef2ad7be7ff
parent63623fe8c03b9c59be9d177364b9eef5b215c16d (diff)
downloadaur-cc42a10be90b1cf0b1837cdf74f3246c6058ccb1.tar.gz
bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66e7f5add008..03476a730155 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Wed Oct 19 20:55:46 UTC 2016
pkgbase = vapoursynth-plugin-sharpaamcmod-git
pkgdesc = Plugin for Vapoursynth: sharpaamcmod (GIT version)
pkgver = r4
@@ -11,7 +13,7 @@ pkgbase = vapoursynth-plugin-sharpaamcmod-git
provides = vapoursynth-plugin-sharpaamcmod
conflicts = vapoursynth-plugin-sharpaamcmod
source = sharpaamcmod::git+https://gist.github.com/8fee7aa32ba9ac566ed0.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-sharpaamcmod-git
diff --git a/PKGBUILD b/PKGBUILD
index ca7bd937337b..b9ebfba07fb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,18 @@ pkgver=r4
pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('any')
-url="https://gist.github.com/4re"
+url='https://gist.github.com/4re'
license=('GPL')
-depends=('vapoursynth' 'vapoursynth-plugin-havsfunc')
+depends=('vapoursynth'
+ 'vapoursynth-plugin-havsfunc'
+ )
makedepends=('git')
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://gist.github.com/8fee7aa32ba9ac566ed0.git")
-sha1sums=('SKIP')
-_sites_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
+sha256sums=('SKIP')
+
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
pkgver() {
cd "${_plug}"
@@ -22,5 +25,7 @@ pkgver() {
}
package() {
- install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_sites_packages}/${_plug}.py"
+ install -Dm644 "${_plug}/${_plug}.py" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/${_plug}.py"
}