summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072022-03-13 18:09:42 +0100
committersL1pKn072022-03-13 18:09:42 +0100
commit02b587f9d990dbdf873f5c4e5f04825faac51f38 (patch)
tree3d69623adcc02ebb09f864bcc80dd44f4b7ed169
parent8ce23a93b227a5aff5892b6cbc9c802e2390c60c (diff)
downloadaur-02b587f9d990dbdf873f5c4e5f04825faac51f38.tar.gz
bump
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 16efd4002800..1437a1a78ff8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vapoursynth-plugin-smoothuv-git
pkgdesc = Plugin for Vapoursynth: smoothuv (GIT version)
- pkgver = v2.0.g0ba81c9
- pkgrel = 2
+ pkgver = 2.1.gd75886e
+ pkgrel = 1
url = https://forum.doom9.org/showthread.php?t=175520
arch = x86_64
license = GPL
@@ -10,6 +10,7 @@ pkgbase = vapoursynth-plugin-smoothuv-git
depends = vapoursynth
provides = vapoursynth-plugin-smoothuv
conflicts = vapoursynth-plugin-smoothuv
+ options = debug
source = smoothuv::git+https://github.com/dubhater/vapoursynth-smoothuv.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 04385ad2e9b0..6dffb7f66d79 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
_plug=smoothuv
-pkgname=vapoursynth-plugin-${_plug}-git
-pkgver=v2.0.g0ba81c9
-pkgrel=2
+pkgname="vapoursynth-plugin-${_plug}-git"
+pkgver=2.1.gd75886e
+pkgrel=1
pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
arch=('x86_64')
url='https://forum.doom9.org/showthread.php?t=175520'
@@ -16,12 +16,13 @@ provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
sha256sums=('SKIP')
+options=('debug')
_site_packages="$(python -c 'import sysconfig; print(sysconfig.get_paths()["purelib"])')"
pkgver() {
cd "${_plug}"
- echo "$(git describe --long --tags | tr - .)"
+ echo "$(git describe --long --tags | tr - . | tr -d v)"
}
prepare() {
@@ -30,7 +31,8 @@ prepare() {
build() {
cd build
- CXXFLAGS+=' -fpeel-loops' arch-meson "../${_plug}" \
+ CXXFLAGS+=' -fpeel-loops' \
+ arch-meson "../${_plug}" \
--libdir /usr/lib/vapoursynth
ninja