summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072018-06-16 15:38:04 +0200
committersL1pKn072018-06-16 15:38:04 +0200
commit033dd4d2f0206f741f66cb4dc4fac236ab92bbfe (patch)
tree0940b8d3a40162c5f978cd732e1f7ae1a999ac8c
parenteab1f8c5d46f93e638c70fae378164850ff67f70 (diff)
downloadaur-033dd4d2f0206f741f66cb4dc4fac236ab92bbfe.tar.gz
bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e60f8cdf236..19be88e3287f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Jun 16 13:33:20 UTC 2018
+# Sat Jun 16 13:38:00 UTC 2018
pkgbase = vapoursynth-plugin-smoothuv-git
pkgdesc = Plugin for Vapoursynth: smoothuv (GIT version)
pkgver = v1.1.g0671808
@@ -13,7 +13,7 @@ pkgbase = vapoursynth-plugin-smoothuv-git
provides = vapoursynth-plugin-smoothuv
conflicts = vapoursynth-plugin-smoothuv
source = smoothuv::git+https://github.com/dubhater/vapoursynth-smoothuv.git
- sha1sums = SKIP
+ sha256sums = SKIP
pkgname = vapoursynth-plugin-smoothuv-git
diff --git a/PKGBUILD b/PKGBUILD
index 9455038e4ada..20dc30cdfd9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,9 @@ makedepends=('git'
provides=("vapoursynth-plugin-${_plug}")
conflicts=("vapoursynth-plugin-${_plug}")
source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
-sha1sums=('SKIP')
+sha256sums=('SKIP')
+
+_site_packages="$(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")"
pkgver() {
cd "${_plug}"
@@ -38,4 +40,8 @@ build() {
package(){
DESTDIR="${pkgdir}" ninja -C build install
install -Dm644 "${_plug}/readme.rst" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
+
+ install -Dm644 "${_plug}/RainbowSmooth.py" "${pkgdir}${_site_packages}/RainbowSmooth.py"
+ python -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/RainbowSmooth.py"
+ python -OO -m compileall -q -f -d "${_site_packages}" "${pkgdir}${_site_packages}/RainbowSmooth.py"
}