summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsL1pKn072018-06-16 15:33:20 +0200
committersL1pKn072018-06-16 15:33:20 +0200
commiteab1f8c5d46f93e638c70fae378164850ff67f70 (patch)
tree514cd51412ebd14460fecb9c92f443a5304e29f7
downloadaur-eab1f8c5d46f93e638c70fae378164850ff67f70.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e60f8cdf236
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Jun 16 13:33:20 UTC 2018
+pkgbase = vapoursynth-plugin-smoothuv-git
+ pkgdesc = Plugin for Vapoursynth: smoothuv (GIT version)
+ pkgver = v1.1.g0671808
+ pkgrel = 1
+ url = https://forum.doom9.org/showthread.php?t=175520
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = meson
+ depends = vapoursynth
+ provides = vapoursynth-plugin-smoothuv
+ conflicts = vapoursynth-plugin-smoothuv
+ source = smoothuv::git+https://github.com/dubhater/vapoursynth-smoothuv.git
+ sha1sums = SKIP
+
+pkgname = vapoursynth-plugin-smoothuv-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9455038e4ada
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+
+_plug=smoothuv
+pkgname=vapoursynth-plugin-${_plug}-git
+pkgver=v1.1.g0671808
+pkgrel=1
+pkgdesc="Plugin for Vapoursynth: ${_plug} (GIT version)"
+arch=('x86_64')
+url="https://forum.doom9.org/showthread.php?t=175520"
+license=('GPL')
+depends=('vapoursynth')
+makedepends=('git'
+ 'meson'
+ )
+provides=("vapoursynth-plugin-${_plug}")
+conflicts=("vapoursynth-plugin-${_plug}")
+source=("${_plug}::git+https://github.com/dubhater/vapoursynth-${_plug}.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${_plug}"
+ echo "$(git describe --long --tags | tr - .)"
+}
+
+prepare() {
+ mkdir -p build
+
+ cd build
+ arch-meson "../${_plug}" \
+ --libdir /usr/lib/vapoursynth
+
+}
+
+build() {
+ ninja -C build
+}
+
+package(){
+ DESTDIR="${pkgdir}" ninja -C build install
+ install -Dm644 "${_plug}/readme.rst" "${pkgdir}/usr/share/doc/vapoursynth/plugins/${_plug}/readme.rst"
+}